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Abstract Abstract 
Audacity is a multi-platform free, open-source audio recorder and editor software. The advantage of 
Audacity software is as follows: easy installation and simple visual interface, no registrations or hardware 
requirements, and availability at no cost might make it a preferred software to carry out class 
demonstrations and lab activities for an undergraduate course in the Communication Sciences and 
Disorders discipline. The tutorial aims to illustrate how Audacity software can be used to demonstrate 
various psychoacoustic phenomena commonly taught in undergraduate Hearing Science courses. This 
tutorial is divided into fundamental and advanced concepts from the pedagogy and student learning 
standpoint. The fundamental concepts involve using sine waves to demonstrate frequency, amplitude, 
and phase related to auditory perception. The advanced concepts include the generation of complex 
periodic non-speech signals, wave superposition, beats, missing fundamental frequency, demonstration 
of different filters, and amplitude and frequency modulation. Future research is needed to evaluate the 
benefits of using Audacity software for psychoacoustical demonstrations in an undergraduate Hearing 
Science course. 
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Introduction 

There has been a significant rise in information and communication technology integration (ICT) 
into college education, which changed the way of teaching in class and transformed instructors 
into mediators (Waldman, 2007). The current literature on ICT in pedagogy highlights the possible 
application and advantages of computer-based activities in the classroom. Based on previous 
reports, Fu (2013) proposed that ICT aids in self-directed and student-centered learning;  promotes 
creativity in learning environments,  provides numerous chances to improve critical thinking skills, 
and encourages collaborative learning in an online learning setup. 
 
In education, the delivery of knowledge using software has influenced various college-level 
academic programs globally. The use of educational software can aid educators in creating 
instructional strategies that accommodate the various learning styles of students in communication 
sciences and disorders (CSD) (Doshi, 2023). Based on Fleming and Mills' (1992) research, 
learning styles can be categorized into visual, auditory, and kinesthetic modalities. Visual learners 
prefer visual stimuli, making it easier for them to comprehend information related to hearing 
science or acoustics by examining graphs, spectrograms, or manipulating waveforms using audio 
editing software (Busan, 2014). Conversely, the auditory style involves a greater propensity for 
auditory input, enabling learners to easily absorb information through listening. Aural learners 
benefit from using audio editing software to generate and modify acoustic signals, facilitating their 
understanding of the impact of different parameters on sound. Lastly, kinesthetic learners require 
active participation in the learning process, engaging in hands-on tasks using an audio editing 
software and connecting theoretical concepts with software-based demonstrations. Software-based 
assignments and experiments provide optimal opportunities for these learners to grasp concepts 
effortlessly (Busan, 2014). Therefore, the utilization of educational software has the capacity to 
cater to students possessing all three of these learning styles. Like any other major, the 
communication sciences and disorders discipline must increase the integration or use of novel and 
relevant software in various courses to enhance learning and improve the quality of education.  
 
This tutorial consists of demonstrations of various psychoacoustical phenomena using Audacity 
software and is written to motivate instructors and students to use Audacity software to enhance 
learning in physics-based undergraduate-level courses on hearing science or acoustics in the CSD 
discipline. The tutorial effectively presents fundamental and advanced concepts in a sequential 
manner, providing step-by-step instructions. The tutorial primarily emphasizes the engagement of 
students in diverse experiments pertaining to the field of hearing science. Nonetheless, instructors 
are also able to adopt these instructions and carry out these experiments within the classroom 
setting, serving as a means to illustrate the underlying concept. 
 
This tutorial serves as a supplement to commonly taught basic and advanced concepts related to 
hearing sciences in the CSD program, and thus, only a minimum explanation of the psychoacoustic 
phenomena is provided. It is expected that these topics are introduced prior to the use of these 
demonstrations. The psychoacoustical demonstrations mainly target the introductory hearing 
science/acoustic/psychoacoustic course offered in most undergraduate CSD programs. This course 
provides the foundations for core undergraduate audiology courses, which is generally considered 
to be one of the most challenging courses. Research supports that hands-on demonstration can 
effectively engage students, generate interest in a topic, and enhance student learning (Ates & 
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Eryilmaz, 2011; Raggozine, F, 2012; Stohr-Hunt, 1996). Demonstrations created using Audacity 
software can clarify intricate physics-based acoustic principles by offering auditory and visual 
feedback to the learner.  
 
This tutorial aims to promote the use of Audacity software in the discipline of CSD by showing its 
application in teaching and demonstrating basic and advanced concepts related to hearing science 
or acoustics. This tutorial intends to provide psychoacoustical demonstrations of non-speech 
sounds using Audacity software which can be implemented in a few courses in the discipline of 
CSD. These demonstrations improving student engagement and learning would lay a strong 
foundation for the remaining undergraduate and graduate communication disorders courses. The 
unique features and advantages of the Audacity software are mentioned in the next section.  
 

Audacity software and its advantages 

Audacity is a freely available, open-source audio recording and editing software that functions 
across multiple platforms. It was created by Mazzoni and Dannenberg in 1999 at Carnegie Mellon 
University. The subsequent year saw its release as open-source software on SourceForge.net. The 
software provides several advantages:  

1. It is open source, granting users the right to utilize, modify, study, and distribute its source 
code for any purpose;  

2. It features a straightforward installation process and a user-friendly visual interface;  
3. It supports various operating systems, including Windows (32 and 64-bit), Mac (64-bit), 

and Linux (64-bit);  
4. It is compact in size, with a setup file of less than 50 MB, and does not demand substantial 

RAM capacity;  
5. It enables the production of diverse sounds such as pure tones, white noise, pink noise, and 

chirps;  
6. It allows users to record, play, and edit audio files in multiple formats such as WAV, AIFF, 

FLAC, MP2, and MP3;  
7. It permits the simultaneous manipulation of one or more acoustic signal parameters;  
8. It facilitates the analysis of acoustic signals through waveform and spectrogram views;  
9. Unlike PRAAT software, Audacity offers an extensive array of features and effects to 

generate and edit acoustic signals;  
10. It also offers the option to incorporate plugins. By accessing the Audacity forum 

(https://forum.audacityteam.org/), users can join a community of developers from different 
countries who share their own plugins. Adding these plugins to the software expands its 
capabilities beyond the default features of Audacity. For instance, this manuscript explores 
advanced concepts such as amplitude and frequency modulation, which were not initially 
included in the Audacity software. Two plugins from the Audacity forum were integrated 
into the original version of Audacity to incorporate these features.  

11. Additionally, a portable version of the software is available, enabling users to install it on 
a USB flash drive, portable hard drive, or any other portable device for use on any 
computer.  
 

Due to the aforementioned advantages, Audacity is a preferred software choice for conducting 
class demonstrations and laboratory activities in undergraduate Hearing Science courses. To 
download Audacity, visit https://www.audacityteam.org/download/.  
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Along with the aforementioned benefits, the Audacity software enables instructors and students to 
manipulate one or more parameters of the acoustic signal, allowing for visual and auditory 
perception of the resulting modifications. Moreover, it provides the chance to visually analyze the 
acoustic signal in various ways, including waveform, spectrogram, and spectrum plot.  
 
Audacity software can be implemented for synchronous in-class or synchronous online 
demonstrations and asynchronous online demonstrations by instructors. Instructors and students 
can perform these demonstrations on a personal computer in class or at home with minimal 
computer proficiency.  
 
This tutorial provides detailed instructions for various psychoacoustical demonstrations which are 
commonly taught in undergraduate and graduate level courses on acoustics, psychoacoustics, or 
hearing science in CSD programs. This tutorial is divided into fundamental and advanced concepts 
from the standpoint of pedagogy and student learning. The fundamental concepts involve using 
sine waves to demonstrate frequency, amplitude, and phase related to auditory perception. The 
advanced concepts include the generation of complex periodic non-speech signals, wave 
superposition, beats, missing fundamental frequency, amplitude modulation, frequency 
modulation, and demonstration of different filters.  
 
Setting up and Exploring Audacity Software 

 

The detailed manual on Audacity software can be found at the link 
(https://manual.audacityteam.org/index.html#), but we also provide essential information on 
setting up and exploring audacity software which is relevant to the psychoacoustical 
demonstrations discussed in this tutorial. The comprehensive online manual for Audacity is vast, 
and it could potentially require weeks or even months for a student to grasp the utilization of the 
Audacity program in CSD undergraduate or graduate courses. This tutorial aims to expedite the 
learning process for instructors and students by providing a concise means to comprehend and 
apply the Audacity software in teaching and comprehending the prevalent fundamental and 
advanced concepts associated with the field of hearing science.  
 
It is recommended that a new user should get familiarized with some basic features of Audacity 
software. The graphical user interface (GUI) of Audacity software changes with the size of the 
window or with the platform (i.e., Mac, Windows, and Linux), and this difference in GUI causes 
a shift in the location of some icons and slider. Hence, the location of buttons may differ from the 
figures added in this tutorial. The figures and explanations in this tutorial are captured from the 
Audacity software in the Microsoft Windows platform. Some of the steps or commands may be 
slightly different when using the Mac platform.  
 

The user should use Audacity software's default values for all the demonstrations discussed in this 
tutorial. As we progress in this tutorial, the first letter of the names of buttons, icons, menu items, 
and toolbars will be capitalized to enhance clarity. To indicate a series of commands that the 
student or user should follow, the > symbol will be used between consecutive commands. For 
example, the instructions, "From the Menu Bar, select Tracks > Add New> select Mono Track" 
means first to identify the Menu Bar at the top, then click the "Tracks" and then click the "Add 
New" button, and lastly, select "Mono Track.” 
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Few of the demonstrations in this tutorial require students or instructors to work with individual 
tracks, each containing waveforms of different sounds. For example, Figure 1 shows three tracks: 
the top track contains a waveform of a fundamental frequency, the middle track contains the second 
harmonic, and the bottom track includes the fourth harmonic of the fundamental frequency. When 
working with multiple tracks in this tutorial, the topmost track will be called Track 1, the next 
track as Track 2, and so on. As mentioned previously, this tutorial has been divided into two major 
sections, fundamental concepts, and advanced concepts, and these major sections are further 
divided into subsections. Before exploring a new topic from a given section, it is recommended to 
close all previous Audacity windows used in earlier sections. 
 
Figure 1 

The Audacity Software Window with three sine wave tracks of 1000, 2000 and 4000 Hz showing 

the location of Zoom In, Zoom Out, Fit Selection, Fit Project, Output Volume Slider buttons and 

Track Control Panels 

 

 

Calibration. Students should confirm which playback device to be used for demonstrations by 
selecting Audio Setup > Playback Device > select the appropriate device options (see Figure 1). 
Following this, it is strongly recommended that the user calibrate the loudness level before using 
the Audacity software for hearing science-related demonstrations. Calibration of loudness is a 
crucial preliminary step that will protect the user's hearing and the instrument (speaker or 
transducer). It is known that the loudness perception varies with the listening situation. Thus, it is 
appropriate for a user to perform calibration using the same listening environment that the user is 
going to use for the demonstrations or task. When opening the Audacity software, the project 
window will pop up (Figure 2). As an initial exercise, the user will create a 3500 Hz sine wave at 
the highest amplitude, and use Audacity's internal volume button to fine-tune the loudness level. 
The user should click and drag the speaker volume slider to zero (Figure 1 - see Audio Input or 
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Output Control). The user should select Generate > Tone from the Menu Bar. The tone generator 
window will appear. A drop-down list will open up by clicking the small downward-facing arrow 
to the right of the waveform box, allowing the user to select a type of waveform. Most of the 
upcoming demonstrations in this tutorial involve sine waves, so the user should choose a sine 
waveform. The tone generator window also allows students to select the sine wave's amplitude, 
frequency, and duration. Students should left-click on the Frequency (Hz) box and enter 3500 as 
the value. The authors recommend this frequency for the loudness calibration because it is the 
median frequency of human hearing's most sensitive frequency range of 2-5 kHz (Gelfand, 2010). 
After putting 3500 Hz in the Frequency (Hz) box, students should left-click in the Amplitude box 
(0–1) and enter 1.00 to generate a sine wave at maximum amplitude. Entering a value greater than 
1 in the amplitude box will produce a sine wave with a maximum amplitude of 1. This default 
control of amplitude is beneficial because 1 is the largest amplitude one can use without inducing 
distortion in the sound, called clipping. Clipping can cause potential damage to the transducer or 
speaker and produce distorted and uncomfortable loud sounds. If a demonstration requires playing 
multiple tracks simultaneously, students should remember that the amplitude of sine waveforms 
are additive and the amplitudes of individual waveforms never summed up to exceed 1; otherwise, 
the sound will get distorted.  

 
Figure 2 

The Default Audacity Window with no Tracks Showing the Location of the Menu Bar, Transport 

Tool Bar, and Buttons of Mic Volume Slider and Output Volume Slider 
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After setting up the waveform’s frequency and amplitude, students should set the duration by 
clicking the arrow to the right of the duration box. Students will see multiple options in the drop-
down menu of duration. However, to keep things simple in this tutorial, it is recommended to use 
the seconds option from the drop-down list of duration and put a 15 seconds value in the duration 
box, which will display as "000,015" seconds (Figure 3). Fifteen seconds is recommended because 
it is sufficient for calibrating the loudness. Clicking on Generate will result in the generation of 
the specified sine wave. Now, students can play the sine waveform by pressing the Play button 
(►) in the Transport Toolbar. When the track is playing, students should use the output volume 
slider to control the volume so that the tone is comfortably loud and clear. Once the output volume 
slider is set at a comfortable loudness level, the student can stop playback by pressing the Stop 
button (■) in the Transport Toolbar. 
 
Figure 3 

The Tone Generator Dialogue Box Showing Frequency, Amplitude, and Duration Parameters 

 

 
 
Once the loudness is calibrated, students can analyze the generated sine wave. Students should 
play the sine waveform again and pay attention to characteristics of sound quality, often described 
as simple or pure sound because of a single frequency component. To see individual cycles of the 
waveform clearly, students should click the Zoom In button multiple times until the individual 
cycles of the waveform appear. If the users want to see the waveform from the beginning, then 
they should click the Skip-To-Start button ( |◄). After zooming in adequately, students will see 
smooth and regular sinewave shapes. The amplitude is indicated by vertical height on Y-axis with 
values ranging from -1.0 to 1.0, and frequency is represented by the number of cycles occurring 
per second. Since the amplitude in this waveform of 3500 Hz was set at the maximum value (i.e., 
1), it can be seen that the waveform covers up the entire distance of the vertical axis of amplitude 
(1 to -1). In addition, students should be able to count the number of cycles in one second of this 
3500 Hz tone. One easy way to calculate and confirm the number of cycles per second is by 
selecting any time frame of 10 milliseconds or 0.01 second of this 15-seconds-long waveform and 
calculating the number of cycles within that time frame. Students will notice that there are 35 
cycles in a 10 milliseconds time frame, which also indirectly confirms that there are 3500 cycles 
in 1000 msec or 1 second of this waveform of 3500 Hz. If a student wishes to return to the original 
view, they can click the Fit Project icon (as shown in Figure 1) or the Zoom Out button ( ) 
multiple times. 
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Fundamental Concepts 

Frequency and Pitch. To show the relationship between frequency and pitch, students will work 
with multiple pure tones or simple sounds to compare their pitch. Before beginning this 
demonstration, it is recommended that students should clear up all the previous audio files in the 
Audacity software by clicking “x” next to the audio tracks. Students will create multiple tracks of 
frequencies 1000, 2000, and 4000 Hz within an Audacity window in a step-by-step fashion, as 
shown in Table 1. After generating all three tracks, students should now be able to see each wave 
individually on their screens. 
 
To play pure tone tracks separately, students can press the Mute button in the Track Control Panel 
(Figure 1) for any other tracks they do not wish to listen to. The Mute button will change its shade 
when activated, and the muted pure tone waveform/s will turn from blue to gray. Specifically, to 
hear track 1 by itself, students should mute tracks 2 and 3 and then press Play. Then, students 
should mute tracks 1 and 3 and disable the Mute button of track 2. Students can then play track 2 
by itself. 
 
Lastly, students should mute tracks 1 and 2 and unmute track 3 in order to play track 3 by itself. 
After listening to the three tracks by themselves, students will perceive that the pitch of the third 
track is highest while the pitch of the first track is lowest. The two consecutive tracks out of the 
three tracks used in this demonstration maintain an interval of an octave, a frequency ratio of 2:1. 
For analyzing the difference in the waveforms of these three tracks, students may click the Zoom 
In button multiple times until the individual cycles of the wave appear. Students will see that the 
highest frequency sinewave in track 3 goes through four cycles in the same amount of time that 
the lowest frequency sinewave in track 1, as shown through the three tracks in Figure 1. Students 
can also compare these three waveforms' energy concentrations by looking at their corresponding 
spectrograms.  
 
Spectrograms are a three-dimensional representation of the signal with time on the x-axis, 
frequency on the y-axis, and sound energy or intensity by the darkness or color on the spectrogram. 
Spectrograms are ideal for displaying the time-varying complex signal. Students should see a small 
toolbar to the left of each wave. At the top of each waveforms’ toolbar, it says "Audio 1," "Audio 
2," and "Audio 3," respectively. To the right of that, there is a small downward-pointing arrow. 
Click on the arrow, and students will see a drop-down box where they can select "spectrogram." 
Students should do this for all three tracks. Students will see that the energy is concentrated at one 
frequency for each of the waves. The energy for track 1 is concentrated at 1000 Hz because it is a 
1000 Hz wave, while the energy at track 2 is concentrated at 2000 Hz, and the energy for track 3 
is concentrated at 4000 Hz. Audacity also offers a Multiview feature by which one can see the 
waveform and corresponding spectrogram in the same window. To activate the Multiview feature, 
students should left-click on the downward-pointing arrow in the track control panel and then 
select Multiview from the drop-down box. 
 
 
 

 

7

Washnik et al.: Using Audacity Software for Teaching Hearing Science Course

Published by ISU ReD: Research and eData, 2023



 
 

Table 1 

Steps for Generating Multiple Pure Tones for the Demonstration of Relationship Between 

Frequency and Pitch. 

 

Track Steps                 Description 
Track 1 (1000 Hz) Step 1 Generate a tone by referring to the Menu Bar, then click on 

Generate > Tone > Waveform = Sine; Frequency (Hz) 
=1000 Hz; Amplitude (0-1) = 0.5; Duration → select 
seconds from the drop-down list → 5 seconds. 

Step 2 Click Generate 
Step 3 Deselect the current waveform by choosing Select > None 

from the Menu Bar. It is important for students to verify 
that they have deselected the pure tone track they recently 
generated before generating the new tone of higher 
frequencies; otherwise, they may unintentionally 
overwrite a previously generated pure tone waveform. 

Track 2 (2000 Hz) Step 1 In the same Audacity window where a tone of 1000 Hz was 
created, generate a tone of 2000 Hz. For generating a tone 
of 2000 Hz, click on click on Generate > Tone > 
Waveform = Sine; Frequency (Hz) =2000 Hz; Amplitude 
(0-1) = 0.5; Duration → select seconds from the drop-
down list → 5 seconds.  

Step 2 Click Generate 
Step 3 Deselect the waveform that was recently created by choosing 

Select > None from the Menu Bar. 
Track 3 (4000 Hz) Step 1 In the same Audacity window where pure tones of 1000 and 

2000 Hz were created, generate a tone of 4000 Hz. For 
generating a tone of 2000 Hz, click on click on Generate > 
Tone > Waveform = Sine; Frequency (Hz) =2000 Hz; 
Amplitude (0-1) = 0.5; Duration → select seconds from 
the drop-down list→ 5 seconds.  

Step 2 Click Generate 
Step 3 Deselect the waveform that was recently created by choosing 

Select > None from the Menu Bar. 
 
Amplitude. The amplitude of an acoustic signal is associated with the perception of loudness. To 
examine amplitude's effect on pure tones, students should generate two pure tone tracks of the 
same frequency and duration but with different amplitudes. For example, generate the first track 
of a 1000 Hz sine wave with an amplitude of 1.0 and duration of 5 seconds, and the second track 
of a 1000 Hz sine wave with an amplitude of 0.2. Detailed step-by-step instructions for this 
demonstration are shown in Appendix A. On analyzing the waveforms of these two tracks visually, 
students will see that these two waveforms have the same frequency, but the amplitude of the sine 
wave in the first track is higher compared to the amplitude of the sine wave in the second track. 
Students should also try to play the first and second tracks by themselves, and they will notice that 
the first track with a relatively bigger amplitude sounds louder than the second track with a 
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relatively smaller amplitude. By enlarging the Track Panel's vertical axis (height), students can 
accurately measure the amplitude of the waveform. The amplitude of a sine waveform can be 
expressed in two ways (i.e., peak-to-peak amplitude and peak-to-baseline amplitude). In Figure 4, 
the peak-to-peak amplitude and peak-to-baseline amplitude are shown yellow and orange arrows, 
respectively. In Figure 4, the peak-to-peak amplitude is 2, while peak to baseline amplitude is 1. 
 
Furthermore, the drastic difference in the amplitude of the first and second tracks is also evident 
in the spectrogram view, as shown in Figure 5. The spectrogram of the first and second tracks 
shows that the energy is concentrated at 1000 Hz. However, the width of the white-pink horizontal 
line representing energy concentration is much thicker (showing high energy concentration) in the 
first track compared to the second track. 
 
Figure 4 

The Audacity Window Showing the Peak-to-Peak and Peak-to-Baseline Amplitude 

 

 

Phase.  Sine waves occur in cycles; that is, they advance through repetitions. The phase of a sound 
wave is the difference in degrees between a point in a cycle and its origin. It indicates the position 
or timing of a point within a cycle of a repetitive sound wave. A completed cycle of sine wave 
runs for 360 degrees. It is easy to compare the perimeter of a circle and a single cycle of a sine 
wave, as shown in Figure 6 (Panel A). Phase can also be described in terms of the relative phase 
angles of two sine waves. For example, if one sine wave starts at 0 degrees of phase angle and the 
second sine wave starts at 180 degrees of phase angle, the two sine waves are 180 degrees out of 
phase with each other. In Figure 6 (Panel B), the red and yellow waves are in phase (1); 180 degrees 
out of phase (2), and 90 degrees out of phase (3). 
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Figure 5 

The Audacity Window Showing Spectrogram View of Two Sine Wave Tracks of Frequency 1000 

Hz with Amplitude 1.0 (top track) and 0.2 (bottom track).  

 

 

Figure 6 

Phase Relationship 

 

 
Note: Panel A illustrates a comparison between a circle and one complete cycle of a sine wave by comparing a 
circle with a sine wave. Panel B shows two sine waves of the same frequency and amplitude at the same phase (1), 
180 degrees out of phase (2), and 90 degrees out of phase (3) 
 
To demonstrate the concept of phase difference between two sine waves, students should generate 
2 sine wave tracks of 500 Hz with a duration of 2 seconds and amplitude of 1.0. Detailed step-by-
step instructions for this demonstration are shown in Appendix B.  After generating these two 
tracks of sine waves; students should select the second track and, from the Menu Bar, select Effect 
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> Invert (On Mac, select Effect > Special > Invert). By pressing the Skip-To-Start button ( |◄ ) 
and zooming in, students will see that the phase of the second track's sine wave is 180 degrees out 
of phase with the sine wave of the first track. Moreover, in order to see the effect of phase on 
sound, students should play the first and second tracks separately. Students will perceive no sound 
difference between the first and second tracks because humans cannot perceive the starting phase 
difference between two sine waves.  
 
Advanced Concepts 

Wave Interference and Beats. The phase parameter of a sound wave plays a vital role in wave 
interference. Wave interference is a phenomenon in which two waves combine by their 
displacement together at every single point in time and space to create a resultant wave of higher, 
lower, or the same amplitude. The two important examples of wave interference that offer the most 
straightforward outcomes are pure constructive interference and pure destructive interference. 
Constructive interference describes a condition where the two sine waves of the same amplitude 
and frequency are in phase, causing the crests or troughs of two interfering sine waves to meet, 
resulting in a wave of amplitude equal to the sum of amplitudes of the original two sine waves. On 
the other hand, destructive interference is a condition where the two sine waves of the same 
frequency and amplitude are 180 degrees out of phase, causing the crest of one sine wave to meet 
the trough of another wave, and the amplitude of these waves cancel each other out. To 
demonstrate constructive interference, students will carry out this experiment step by step. In the 
first step, students should generate 2 sine wave tracks of 500 Hz with a duration of 2 seconds and 
amplitude of 0.5. In the second step, students should select both tracks by choosing Select > All 
from the Menu Bar and then clicking on Tracks > Mix > Mix and Render to New Track. A new 
track will be created at the bottom, showing the result of constructive interference in the form sine 
wave whose amplitude is the sum of the amplitude of two original sine waves (left panel of Figure 
7).  
 
To show destructive interference, students will open another window of Audacity by clicking on 
File > New in the Menu Bar. Similar to the first step in the constructive interference demonstration, 
students should create 2 sine waves with the same parameters. After generating two sine wave 
tracks of 500 Hz, students should select the second track and click on Effect > Invert (on Mac, 
select Effect > Special > Invert) from the Menu Bar. In the next step, students will select both 
tracks by choosing Select > All from the Menu bar. Once both tracks are selected, students will 
choose Tracks > Mix > Mix and Render to New Track. A new track showing a flat line will appear 
at the bottom (right panel of Figure 7). This flat line represents that the two waves of the same 
phase frequency and amplitude but completely opposite in phase cancel each other out. Students 
will not hear any sound in this situation. 
 
Wave interference also occurs between two sine waves of slightly different frequencies, which 
induces audible fluctuations called beats. Beats can be divided into monoaural beats and binaural 
beats. Monoaural beats occur when two sine waves of slightly different frequencies are presented 
to only one ear of a subject. On the other hand, binaural beats occur when a pure tone is presented 
to one ear and another tone of a slightly different frequency is presented to another ear. The 
Audacity software allows the instructor or student to generate monaural and binaural beats. The 
steps for demonstrating binaural and monoaural beats are shown in Table 2. Students need to use 
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headphones or earphones for this demonstration. After completing step 4 from Table 2, students 
will be able to hear the audible fluctuations or beats. Monoaural beats typically sound more robust 
than binaural beats. Because of the frequency difference of 5 Hz between the two tones, the 
students will hear 5 beats per second. The rate of beats can be changed by changing the frequency 
difference between the two tones.  
 
Figure 7 

The Audacity Window Showing Constructive Interference (highlighted bottom track, left panel) 

and Destructive Interference (highlighted bottom track, right panel) Between Two Sine Waves of 

500 Hz with an Amplitude of 0.5 

 

 

Students can also show the resultant waveform of beats. To display the resulting beat waveform, 
students should drag the Pan Slider of both tracks to the middle or center. Next, students should 
refer to the Menu Bar and click Select > All. After selecting both tracks, students should click on 
Tracks > Mix > Mix and Render to New Track. This will create a new waveform below the second 
track representing beats. Students can clearly see 5 beats within the one-second timeframe in the 
Audacity window. As mentioned earlier, the 5 beats shown in Figure 8 (third track) are attributed 
to the frequency difference between the two tracks. Furthermore, students will also notice that the 
maximum amplitude of these beats is equal to the sum of the amplitudes of two tones.  
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Table 2  

Steps for the Demonstration of Monoaural and Binaural Beats. 

Step Monoaural Beats Binaural Beats 
Step 1 Generate a tone by referring to the Menu Bar, then click on Generate > Tone > 

Waveform = Sine; Frequency (Hz) = 500; Amplitude (0-1) = 0.5; Duration = 1 
second. 

Step 2 For generating another tone of slightly different frequency in the same window, first, 
refer to Menu Bar and click on Select > None. Next, click on Generate > Tone > 
Waveform = Sine; Frequency (Hz) = 505; Amplitude (0-1) = 0.5; Duration = 1 
second 

Step 3 Go to the Track Control Panel of both 
tracks and drag the Pan Slider of 
both tracks all the way to either 
the left side or right side. This 
arrangement of Pan Slider will 
allow both tracks to be played 
only through one channel (left or 
right)  

Go to the Track Control Panel of the first 
track and drag the Pan Slider all the way 
to the right side. Then, go to the Track 
Control Panel of the second track and 
drag the Pan Slider all the way to the left. 
Setting the Pan Slider this way will result 
in the first track playing only in the right 
ear and the second track only in the left 
ear. 

Step 4  Play both tones simultaneously Play both tones simultaneously 
 

Figure 8 

The Audacity Window Showing the Interaction Between Two Sine Waves of Slightly Different 

Frequencies.  

 

 
Note. The Bottom Track Shows 5 Beats in a Timeframe of 1 Second. The Number of Beats in a Span of One Second 
is Attributed to the Frequency Difference Between Two Sine Waves (i.e., 505-500= 5 Hz). 
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Complex Waves.  A complex wave is made up of a series of sine waves; thus, it is relatively more 
complex than a simple sine wave. In the experiment to demonstrate the concept of complex 
waveforms, students will combine individual sine waveforms to create a complex wave, a process 
known as additive synthesis. Students should generate four sine waves of 250 Hz (first track), 500 
Hz (second track), and 750 Hz (third track) in the same window of the Audacity software. Each 
sine wave should have an amplitude of 0.2 and a duration of 2 seconds. For generating all above 
mentioned three pure tones, students should start with generating 250 Hz tone by referring to the 
Menu Bar and choosing to Generate > Tone (Frequency (Hz) = 250 Hz; Amplitude (0-1) = 0.2; 
Duration = 2 seconds). After setting up frequency, amplitude, and duration, students should click 
Generate (on the right side of the Tone dialogue box). Once the first tone is generated, students 
should attend the Menu Bar, and choose Select > None. Next, students should similarly create a 
500 Hz tone. After creating a 500 Hz tone, students will again attend the Menu Bar and choose 
Select > None. Students will repeat these steps one more time to create a tone of 750 Hz. 
 
After generating these three tracks, students will mix these tracks and create a new fourth track of 
a complex wave. To create the fourth track, students should choose from the Menu Bar > Select > 
All to select all three tracks. After selecting all three tracks, students should attend to the Menu 
Bar again and choose Tracks > Mix and Render to New Track. The fourth track will appear at the 
bottom.  

  
Students should play all these four tracks individually and will perceive that the complex wave in 
track 4 has a distinct timbre than the original three sine waves. Timbre, also called tone color, is 
the characteristic quality of sound that differentiates two sounds of the same frequency or note. 
For example, an individual can clearly perceive the difference in C notes played on a cello and a 
piano. Furthermore, students will sense that they are hearing just one pitch for the fourth track, 
though there are three tracks of different frequencies that were mixed to create the fourth one. 
 
In order to understand the phenomenon of complex waves properly, students should try to 
remember the pitch of the sound when they play the four tracks individually. Eventually, students 
will realize that the pitch of the fourth complex wave matches the pitch of the 250 Hz sine wave 
of the first track. This observation signifies that the perceived pitch of the complex tone 
corresponds to the fundamental frequency. 
 
In the above experiment, students created a complex periodic sound wave by combining a 
fundamental frequency of 250 Hz and a series of its harmonics. Harmonics are described as the 
integer multiples of the fundamental frequency (first harmonic →250 x 1 = 250 Hz; second 
harmonic → 250 x 2 = 500 Hz; third harmonic → 250 x 3 = 750 Hz). Harmonics typically fuse to 
form one auditory image of a complex tone, which is a pitch corresponding to the first harmonic 
or fundamental frequency. One of the great features of the Audacity software is that it allows 
student or user to listen to each harmonic separately, which may help recognize the pitch. Suppose 
students first play these harmonics (i.e., 250 Hz, 500 Hz, and 750 Hz) individually. In that case, 
they may hear the pitches of these individual harmonics in the fourth track of complex tone, which 
typically won't happen with most complex tones for a majority of the listeners (Rasch & Plomp, 
1999).  
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To better understand the relationship between the pitch of the fundamental frequency and complex 
tone, students should zoom in on all four tracks together multiple times until they see a clear sine 
wave of the first three tracks (shown in Figure 9, panel A). Here, students should pay attention to 
the period of each wave. Students will notice that the time a complex periodic wave takes to 
complete one cycle is equal to the 250 Hz sine wave in the first track (Figure 9, panel A). Thus, it 
can be concluded that the pitch and duration of the complex periodic sounds correspond to the 
pitch and duration of the fundamental frequency. 
 
Figure 9 

Illustration of Complex Waves.  

 

 
Note: Panel A illustrates sine waves of frequencies 250, 500, and 750 Hz and the resultant complex wave (bottom 
track). Panel B illustrates sine waves of frequencies 250, 500, 750, and 1000 Hz and the resultant complex wave 
(bottom track). 
 
Furthermore, in an extension of the above experiment, students can also show the influence of 
adding more harmonics on the appearance of the waveform of the complex tone. In order to see 
the effect of adding harmonics on the complex periodic waveform, students should  
keep the old window showing waveforms of 250 Hz, 500 Hz, 750 Hz, and a complex tone, and 
then open a new window of Audacity by using the Menu bar, File > New. A new window of 
Audacity will pop up. Like the previous experiment, students will generate pure tone tracks of 
frequencies 250 Hz, 500 Hz, 750 Hz, and 1000 Hz. Next, students should select all these four 
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tracks as they did earlier. To combine all four pure tone tracks and generate a new complex wave, 
students should refer to the Menu Bar again and choose Tracks > Mix and Render to New Track. 
The fifth track will appear at the bottom (Figure 9, panel B). It is recommended that student should 
zoom in on the waveform adequately. In order to compare the complex waveform, students should 
place both windows side by side. On comparing both windows of Audacity, students will note that 
adding an extra harmonic of 250 Hz (i.e., 4th harmonic = 1000 Hz) in the second window created 
an additional smaller peak on the complex waveform without affecting the complex waveform's 
period (Figure 9).  

 
Missing Fundamental Frequency.  A complex periodic sound is said to have missing 
fundamental or phantom fundamental when its harmonics suggest a fundamental frequency, but 
the actual sound lacks a fundamental frequency component. Detailed step-by-step instructions for 
demonstrating the concept of missing fundamental frequency using Audacity are shown in 
Appendix C. To demonstrate the concept of missing fundamental frequency, students will generate 
4 sine waves of frequencies 250 Hz, 500 Hz, 750 Hz, and 1000 Hz of amplitude 0.2 and duration 
2 seconds. In the next step, students should select all tracks by choosing Select > All. Thereafter,  
choose Tracks > Mix > Mix and Render to create a single complex waveform. After that, students 
should save this track as a single file using the Menu Bar by choosing File> Save Project As, and 
choosing a desired location on their computer. This file should be saved as an Audacity project 
using the name "with the fundamental frequency."  
 
After saving the Audacity project, students will use the existing window of Audacity to create 
another complex waveform. In the next step, students should select Edit > Undo Mix and Render 
to return to the original four harmonics. After that, students will generate a new complex wave 
without the fundamental frequency (i.e., 250 Hz).  
 
To create a complex wave without fundamental frequency, first, the student will select and delete 
the track of 250 Hz. Next, students should select all three remaining tracks of frequencies 500 Hz, 
750 Hz, and 1000 Hz. After that, using the procedure described above, students should mix and 
render these three tracks and save this new complex wave as "without fundamental frequency." 
The aim is to compare the two complex waves in the same window. Subsequently, from the Menu 
bar, students should select File > Open and open the file "with fundamental frequency." By now, 
both files should be open, and students can move back and forth between the two complex wave 
files by clicking the Audacity icon in the taskbar. In the following step, students should copy the 
wave "without fundamental frequency" (by selecting Edit > Copy), then go back to the view of 
"with fundamental frequency," and finally paste the wave (by clicking Edit > Paste) "without the 
fundamental frequency" below the wave "with fundamental frequency." 
 
By this time, students should have two waveforms on one window of Audacity software: "with 
fundamental frequency" is the first track, and "without fundamental frequency" is the second track. 
Students should play these two tracks separately and will realize that both tracks have the same 
pitch. On zooming in, students will observe that the first and second waveforms differ in shapes 
but will also notice that the periodicity (i.e., the time over which the waveform repeats) of these 
two waves is the same. The missing fundamental is also known as virtual pitch. 

 

16

Teaching and Learning in Communication Sciences & Disorders, Vol. 7 [2023], Iss. 3, Art. 4

https://ir.library.illinoisstate.edu/tlcsd/vol7/iss3/4
DOI: 10.61403/2689-6443.1284



 
 

Frequency Range of Human Hearing.  All mammalian species are not sensitive to the same 
range of frequencies. As mentioned in various books on psychoacoustics, humans can detect 
acoustic stimuli in a frequency range from approximately 20 Hz to 20 kHz (Goldstein, 2010). It is 
worth noting that most of the commonly used audio devices, such as headphones or speakers, are 
not designed to produce extreme frequencies, so it is possible that the student may hear some 
distortion or artifactual noises when performing a human auditory range experiment.  
 
In this experiment, students will be required to generate multiple sine waves, and it is 
recommended that students use a duration of 2 seconds and an amplitude of 1.0 for every sine 
wave. The experiment will start with generating a sine wave of 20,000 Hz. It is possible that 
students may not hear any sine wave. Following the 20,000 Hz sine wave, students should create 
a sine wave of 19,000 Hz by overwriting the previous track of the 20,000 Hz sine wave and decide 
whether they can hear the tone now. After that, students should resume the experiment by 
decreasing the frequency of sine waves by 1000 Hz every time and identify the highest audible 
frequency for them.  
 
In the next step, students should create a sine wave of 10,000 Hz, which will be audible to most 
people with normal hearing. Although 10,000 Hz pure tone is a full octave below the upper fence 
of the human hearing range (i.e., 20,000 Hz), it will sound very high-pitched. It is important to 
remember that the frequencies of most musical notes are significantly lower than 10,000 Hz. For 
example, on a violin, the frequency of the highest note is 3520 Hz. 
 
To perceive and analyze the lower fence of the human hearing range, students may generate a tone 
of 20 Hz by overwriting the existing track or by creating a fresh, pure tone track in a new window 
of Audacity by selecting File > New from the Menu Bar. Like the upper fence of the human hearing 
range, many students may not be able to perceive any sound at 20 Hz. In case if the students didn't 
hear the sound, they can overwrite this sine wave of 20 Hz with a slightly higher frequency and 
sequentially increase the frequency in the 5 Hz step until they barely perceive a low-pitched tone.  
 

Effect of Frequency on Loudness.  The human auditory system is not equally sensitive to all 
frequencies. It means that an acoustic signal at one frequency may be perceived louder than another 
acoustic signal of a different frequency but with the same amplitude. For the experiment showing 
the effect of frequency on loudness perception, students will generate a pure tone of 20 Hz with a 
duration of 30 seconds and an amplitude of 0.5. Next, Students should pick Effect > Sliding Stretch 
(on Mac, select Effect > Pitch and Tempo > Sliding Stretch) from the Menu Bar. In the Sliding 
Stretch dialogue box, students should add a value of 0 in the Initial Pitch Shift (semitones) section 
and a value of 12 in the Final Pitch Shift (semitones) section without manipulating any other 
default settings. Then, students should click Apply. This Sliding Stretch effect moves the 
frequency by just one octave. However, one can recursively use this effect to shift the frequency 
by a larger amount. Hence, students should use the same effect using the same instructions (Effect 
> Sliding Stretch for windows and Effect > Pitch and Tempo > Sliding Stretch for Mac) and values 
(Initial Pitch Shift = 0; Final Pitch Shift = 12) nine more times. All these steps will induce a 
continuous and smooth frequency glide from 20 Hz to 20,480 Hz. When students play the final 
track, this wave may sound very soft at the beginning and gradually gets louder as it approaches 
the frequency range (approximately 2000-4000 Hz) at which human hearing is most sensitive 
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(Suzuki & Takeshima, 2004). The loudness of the wave will decrease again as it moves toward the 
upper fence of the human hearing range. 

 
Filters.  An acoustic filter can affect the spectrum of a sound by allowing specific frequencies to 
pass and suppressing or blocking other frequencies. In the context of Hearing Science, the filter 
concept is applied in several domains (e.g., the resonance of concha, ear canal, the combined 
resonance of the external ear, and hearing aids). Filters are labeled according to the spectral change 
they induce. A filter that allows all the low frequencies to pass below a particular cut-off frequency 
and blocks or attenuate all the high frequencies is called a low-pass filter. Conversely, a high pass 
filter allows the passing of only those frequencies which are higher than the designated cut-off 
frequency. In the low pass filter demonstration, students first create a complex sound. Like the 
previous demonstration in the complex wave section, students will generate four pure tones of 
frequencies 200, 420, 6660, and 8300 Hz in the same window of the Audacity software. After 
generating these tones, students should pick from the Menu Bar, Select > All to select all the tracks. 
Next, they should click Tracks > Mix > Mix and Render. To see the energy concentration of the 
newly formed complex wave, students should click on the black arrow (▼) in the Track Control 
Panel, then choose Spectrogram from the list. The student will now see the complex wave's 
spectrogram showing energy concentration in the form of horizontal lines at four original sine 
wave frequencies (200, 420, 6660, and 8300 Hz). In the next step, students should choose Effect 
> Low Pass Filter (on Mac, Effect > EQ and Filters > Low Pass Filter) from the menu bar. In the 
Low-Pass Filter dialogue box, students should enter a value of 500 in the Frequency section, select 
48 dB from Roll-Off (dB per octave) section, and click Apply. Now, students will see a Low-Pass 
Filtered wave's spectrogram showing energy in the form of white-red lines at two frequencies that 
are below the cut-off frequency (500 Hz). The spectrogram also reveals that the two high-
frequency components, 6660 and 8300 Hz, are completely blocked or filtered out.  
 
To demonstrate the concept of a high-pass filter using a complex wave, students should select Edit 
> Undo Low-Pass Filter from the Menu Bar to return to the spectrogram of the original complex 
wave. Next, students should choose Effect > High-Pass Filter (on Mac, Effect > EQ and Filters > 
High Pass Filter) from the menu bar. In the High-Pass Filter dialogue box, students should enter a 
value of 2000 in the Frequency section, select 48 dB from Roll-Off (dB per octave) section, and 
click Apply. Students will see that the energy is only present at two high-frequency components 
(i.e., 6660 and 8300 Hz) represented in the form of white-red lines (Figure 10). Furthermore, 
students will also notice in the resulting spectrogram that the high-pass filter completely blocked 
low-frequency components (i.e., 200 and 420 Hz).  
 
In addition to low-pass and high-pass filters, students can also demonstrate the concept of notch 
filters using Audacity software. A notch filter is typically used to remove only one frequency 
component from complex sounds. For the notch filter demonstration, students can use the previous 
complex file utilized in the low-pass and high-pass filter demonstration. To go back to the original 
complex wave, students should select Edit > Undo High-Pass Filter from the Menu Bar. The 
spectrogram of the original complex wave appears on the window of the Audacity software, and 
by the color of the spectrogram, it is evident that the complex wave is already selected. Let's 
assume that students want to remove only 6660 Hz from the complex wave. For removing 6660 
Hz from the complex wave, students should choose Effect > Notch Filter (on Mac, Effect > EQ 
and Filters > Notch Filter) from the Menu Bar. In the Notch Filter dialogue box, students should 
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enter a value of 6660 Hz in the Frequency section and 1 in the Q (higher value reduces width) 
section and click Apply. Students will now see a notch-filtered spectrogram of a complex wave 
with no energy representation at 6660 Hz (Figure 10). Students will notice only three horizontal 
lines instead of four in the original spectrogram, representing energy at 200, 420, and 8000 Hz.  

 
Figure 10 

The Audacity Window Illustrating the Spectrogram View of a Complex Wave (First Track), Low-

Pass Filtered Complex Wave (Second Track), High-Pass Filtered Complex Wave (Third Track), 

and Notch-Filtered Complex Wave (Fourth Track). 

 

 
 

Amplitude Modulation and Frequency Modulation.  The original version of the Audacity 
software does not provide the option to generate amplitude-modulated (AM) and frequency-
modulated (FM) tones under the "Generate" tab. As previously mentioned, one of the advantages 
of Audacity software is its ability to incorporate plugins that add extra features. These plugins, 
which are developed by creators from different countries, are safe to use. The plugins for 
generating AM and FM tones can be obtained from the following link: 
https://forum.audacityteam.org/t/am-and-fm-tone-generators/29422. Once students or users have 
downloaded the AM and FM tone plugin files, they can copy and paste them into the Plug-Ins 
folder of Audacity. Windows users can locate this folder in the Program Files directory (Mac users 
in applications>Audacity> show package content>contents>plug-ins). After pasting these files, 
students need to open the Audacity software. Subsequently, under the Generate tab, they will find 
the options for the AM tone generator and FM tone generator. 
 
To demonstrate the AM tone, students should begin by generating a 500 Hz tone. They can do this 
by referring to the Menu Bar and selecting Generate > AM Tone Generator. The parameters for 
this tone are as follows: base frequency (Hz) = 500 Hz, base frequency type = sine, modulation 
frequency type = sine, modulation frequency = 0, modulation depth = 0, amplitude = 0.8, and 
duration = 2 seconds. Once all the parameters are set, students should click on Generate in the AM 
Tone generator dialogue box. This will produce a pure tone because the modulation frequency was 
set to 0. Once the first tone is generated, students should deselect any selected tracks by going to 

19

Washnik et al.: Using Audacity Software for Teaching Hearing Science Course

Published by ISU ReD: Research and eData, 2023

https://forum.audacityteam.org/t/am-and-fm-tone-generators/29422


 
 

the Menu Bar and choosing Select > None. Next, they should create another 500 Hz AM tone, but 
this time with a modulation frequency of 10 Hz and a modulation depth of 0.4. This tone will 
exhibit a waveform different from the pure tone, as shown in the second track of Figure 11. 
Students will observe ten crests and troughs within a one-second period, which corresponds to the 
modulation frequency of 10 Hz. The loudness of this tone fluctuates periodically, creating a 
resonating texture, unlike the constant loudness of a pure tone. After creating the first 500 Hz AM 
tone, students should once again deselect any selected tracks by choosing Select > None from the 
Menu Bar. They can then repeat these steps to create another AM tone of 500 Hz, this time with a 
different modulation depth of 1.0. The waveform of this tone, shown in the third track of Figure 
11, exhibits a similar rate of amplitude fluctuation as the middle track due to the identical 
modulation frequency. However, the depth of amplitude fluctuation is comparatively higher, 
resulting in a more pronounced loudness variation. This will help students comprehend the impact 
of modulation depth on AM tones. 
 

Figure 11  

The Audacity Window Illustrating a Waveform View of a 500 Hz Sine Wave (First Track), and 

Two Tracks of 500 Hz Amplitude Modulated Tones with Different Modulation Depth.  

 

 
Note. The second and third tracks represent 500 Hz amplitude modulated (AM) tone with a modulation frequency of 
10 Hz, and modulation depth of 0.4 and 1, respectively. 
 
To demonstrate the FM tone, students should begin by generating a 400 Hz tone. They can do this 
by accessing the Menu Bar and selecting "Generate" followed by "FM Tone Generator." The 
parameters for this tone are as follows: base frequency (Hz) = 400 Hz, base frequency type = sine, 
modulation frequency type = sine, modulation frequency = 0 Hz, modulation width = 0 Hz, 
amplitude = 0.8, and duration = 1 second. Once all the parameters are configured, students are 
advised to click the "Generate" option located in the dialog box of the FM Tone generator. This 
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action will produce a pure tone, depicted as the first track in Figure 12, due to the modulation 
frequency and modulation width being set to 0. 
 
After generating the first tone, students should remove any selected tracks by going to the Menu 
Bar and choosing "Select > None." Next, they should create a 400 Hz FM tone, accompanied by a 
modulation frequency of 5 Hz, while keeping the remaining parameters unchanged. This tone will 
exhibit a waveform distinct from the pure tone, as shown in the second track of Figure 12. Students 
will observe periodic fluctuations in the wavelength of the second track. These periodic 
fluctuations, occurring at a rate of 5 Hz (modulation frequency), indicate periodic changes in 
frequency within the range of 100 Hz (modulation width), alternating between low and high 
frequencies. Perceptually, this tone will produce a periodic variation in pitch. 
 
Upon generating the initial 400 Hz FM tone, students are advised to deselect any chosen tracks by 
navigating to the Menu Bar and selecting "Select > None." Subsequently, they can proceed with 
reproducing these steps to produce another 400 Hz FM tone featuring a modulation frequency of 
10 Hz while keeping the remaining parameters unchanged. The waveform of this tone, depicted in 
the third track of Figure 12, exhibits periodic fluctuations as well. However, these fluctuations 
manifest at a comparatively swifter pace than those in the second waveform due to the higher 
modulation frequency (10 Hz). The third waveform appears compressed in comparison to the 
second waveform, as the same fluctuations occur at twice the rate of the modulation frequency in 
the second waveform. In this tone, students will perceive more rapid pitch variations when 
compared to the second waveform. The disparity in modulation frequency between the second and 
third waveforms will allow students to observe the impact of modulation frequency in FM tones. 
Figure 12 provides a clear visual depiction of the differentiation between a pure tone (first track) 
and an FM tone (second and third tracks). To observe the waveform depicted in Figure 12, it is 
recommended that students zoom in sufficiently such that the complete duration of the waveform, 
measured in seconds, becomes visible within the entire window of Audacity. 
 

Discussion 

 

Audacity is a freely available, open-source audio recording and editing software that functions 
across multiple platforms. The Audacity software offers several advantages for utilization in an 
undergraduate course on hearing science or psychoacoustics. These advantages include the 
following: (a) effortless installation, (b) absence of registration requirements, (c) cost-free 
availability, (d) minimal computer proficiency prerequisites, (e) the capacity to illustrate a majority 
of the psychoacoustic phenomena pertinent to the mentioned course, and (f) a user-friendly visual 
interface that enables the creation and analysis of multiple audio tracks, as well as a multi-view 
feature that simultaneously displays waveforms and spectrograms. Consequently, it can be the 
preferred software for conducting class demonstrations and laboratory activities in an 
undergraduate hearing science or psychoacoustics course. The tutorial aims to demonstrate how 
Audacity software can be effectively employed to illustrate various psychoacoustic phenomena 
typically taught in undergraduate courses within the CSD program. 
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Figure 12 

The Audacity Window Illustrating a Waveform View of a 400 Hz Sine Wave (First Track), and 

Two Tracks of 400 Hz Frequency Modulated (FM) Tone with different Modulation Frequencies 

  

 
Note. The second and third tracks represent 400 Hz frequency modulated (FM) tones with modulation width of 100 
Hz and modulation frequency of 5 and 10 Hz, respectively.  
 

This tutorial is divided into fundamental and advanced concepts to offer an opportunity to design 
assignments or projects as the course progresses through a semester. For example, the first couple 
of assignments may target the fundamental concepts. Once the assignment work by students using 
Audacity software reflects a clear understanding of concepts, the instructor can introduce advanced 
concepts of the Hearing Science course. Performing hearing science experiments using the 
Audacity software and writing required responses to the software-based assignments will 
strengthen students' learning of hearing science concepts. Previous studies evaluating software-
based assignments show that students' responses to these tasks are typically favorable (Aberson et 
al., 2003; Boger & Boger, 1994; Berenguel et al., 2016; Evert et al., 2005; Graham, 1998; Grant, 
2004; Ragozzine, 2002; Scotts, 2006). From a learning perspective, it is advantageous that 
instructors create software-based group assignments for Hearing Science instead of individual 
assignments because students can share what they observe and hear with their group members. For 
example, in one of the group assignment questions, students may be required to create a complex 
periodic sine wave using 3 frequencies, 200 Hz, 400 Hz, and 600 Hz, and report their perception 
through hearing and observing waveforms (simple and complex) individually. Additionally, 
instructors may encourage students to explore other aspects of the complex periodic sound wave, 
such as the resultant amplitude of the complex sound in the waveform view and energy distribution 
in the spectrogram view. Students will discuss their perceptions and observation with their group 
members and collectively report the answer in their group assignment document.  
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It is also possible that instead of using the Audacity software for group assignments, an instructor 
may supplement the in-person or virtual lectures by conducting hearing science experiments using 
the Audacity software in front of the students. It is easy to assume that such activity incorporating 
passive observation of students will be relatively effective in learning when compared to lectures 
utilizing two-dimensional figures and PowerPoint presentations by an instructor. A few 
researchers have shown that this assumption may not hold true. Crouch and colleagues (2004) 
reported that passive observation of experiments is not effective in fostering learning among 
students. Their findings revealed that demonstrations facilitate learning only when an instructor 
engrosses students by making these demonstrations more interactive. For example, an instructor 
may ask students in advance about the possible outcome of a particular experiment. This strategy 
of asking students to envision the outcome is presumably more impactful when results do not 
match their projected outcome (Posner et al., 1982). Hence, if a hearing science related experiment 
using Audacity software is performed in front of the entire class, then the instructor should first 
encourage students to predict the perceptual outcome. Many of the perceptual outcomes of these 
demonstrations are counterintuitive. For example, many students will be astonished when they 
hear no sound in a destructive interference demonstration, or when they hear a missing 
fundamental frequency even though that frequency is physically not present in the sound. Thus, it 
is believed that all the demonstrations covered in this tutorial will complement learning when this 
software is incorporated into individual or group assignments or used by an instructor during a 
class session. 
 
While Audacity software is available at no cost, students' ability to access it depends on instructors 
recognizing the necessity of incorporating the software into classroom presentations and laboratory 
exercises. It is probable that most students will not utilize Audacity software for educational 
purposes unless guided and recommended by their instructors. Therefore, instructors will have a 
significant impact on improving students' accessibility to the Audacity software. Additionally, we 
do not provide a specific list of lab activities that can be implemented for the CSD hearing science, 
acoustics, or psychoacoustics course. Instructors have the flexibility to incorporate either 
individual or group assignments, interactive classroom demonstrations, or both. We encourage 
instructors to develop lab activities based on the various psychoacoustic demonstrations discussed 
earlier, aligning them with the course content and sequence. This approach enables students to 
observe, demonstrate, and report psychoacoustic phenomena, thereby enhancing their 
participation, learning, and retention. All the demonstrations covered in this tutorial utilized non-
speech sounds. The intention behind using non-speech sounds in all these demonstrations is to 
show the foundational concepts of hearing science in the most simplistic manner. Audacity 
software can also be used to record, edit, and analyze speech sounds too. However, in the context 
of undergraduate speech science courses in the Communication Sciences and Disorders discipline, 
many instructors of speech science courses use Praat software. Like Audacity, Praat is a free 
software package.  
 
This tutorial was designed to introduce certain commonly discussed fundamental and advanced 
concepts rather than extensive experiments for all possible advanced topics of hearing science. 
One can use Audacity software for teaching and demonstrating complex advanced topics such as 
transient distortion, amplitude distortion, precedence effect, frequency modulation, lateralization, 
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etc. Hence, the Audacity software can also be utilized in graduate audiology courses like Advanced 
Hearing Science or Psychoacoustics.  
 
To conclude, hands-on demonstration using Audacity software can effectively engage students, 
generate interest in a topic, and enhance student learning. Research is needed, however, to 
investigate the benefits of using Audacity software in an undergraduate Hearing Science course. 
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Appendix A 

 

Demonstration of the influence of amplitude on pure tones 
 

Track 1 
(1000 Hz) 

Step 1 Generate a tone by referring to the Menu Bar, then click on Generate > Tone > 
Waveform = Sine; Frequency (Hz) =1000 Hz; Amplitude (0-1) = 1.0; duration 
→ select seconds from the drop-down list → 5 seconds. 

Step 2 Click Generate 
Step 3 Deselect the recent waveform by choosing Select > None from the Menu Bar. It 

is important to verify that the pure tone track generated earlier is deselected to 
avoid accidentally overwriting a previously generated waveform. After 
completing these steps, your Audacity window will resemble the figure below.  

 
Track 2 
(1000 Hz) 

Step 4 To generate a tone of 1000 Hz with a different amplitude in Audacity, please 
follow these steps: Click on Generate > Tone > Waveform = Sine; Frequency 
(Hz) =1000 Hz; Amplitude (0-1) = 0.2; duration → select seconds from the 
drop-down list → 5 seconds.  

Step 5 Click Generate 
Step 6 Deselect the waveform that was recently created by choosing Select > None 

from the Menu Bar. After completing these steps, your Audacity window should 
resemble the figure below. 
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Step 7 To view the individual cycles of the sine wave, follow these steps: Locate the 
Zoom In button in Audacity. Click on the Zoom In button multiple times until 
the individual cycles of the wave become visible. This will allow you to observe 
the wave in greater detail, as shown in the figure below. 

 
  
Step 8 The impact of amplitude on the sine wave can be readily observed in the 

aforementioned diagram. To audibly discern this impact, it is 
recommended to mute a track by activating the Mute button located in the 
Track Control Panel. This will facilitate a distinct auditory perception of 
the track. To exclusively listen to track 1, individuals should mute track 2 
and subsequently press the Play button. Following that, track 1 should be 
muted while deactivating the Mute button on track 2. At this juncture, 
individuals can independently play track 2. After playing these two tracks 
separately, users will discern the disparity in the loudness of the two 
tones. 
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Appendix B 

 

Demonstration of the influence of phase on pure tones 
 

Track 1 (500 
Hz) 

Step 1 Generate a tone by referring to the Menu Bar, then click on Generate > Tone > 
Waveform = Sine; Frequency (Hz) =500 Hz; Amplitude (0-1) = 1.0; duration 
→ select seconds from the drop-down list → 2 seconds. 

Step 2 Click Generate 
Step 3 Deselect the recent waveform by choosing Select > None from the Menu Bar. 

After completing these steps, your Audacity window will resemble the figure 
below. 

 
 

Track 2 (500 
Hz) 

Step 4 In the same Audacity window where a tone of 500 Hz was created, generate 
another tone of 500 Hz with the same parameters. For generating a second tone 
of 500 Hz, click on click on Generate > Tone > Waveform = Sine; Frequency 
(Hz) =500 Hz; Amplitude (0-1) = 1.0; duration → select seconds from the drop-
down list → 2 seconds.  

Step 5 Click Generate 
Step 6 Deselect the waveform that was recently created by choosing Select > None 

from the Menu Bar. After completing these steps, your Audacity window will 
resemble the figure below. 
 

 
 

Step 7 Select the second track and, from the Menu Bar, select Effect > Invert 
(On Mac, select Effect>Special>Invert). Thereafter, press the Skip-To-
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Start button ( |◄ ) and then press the Zoom In button multiple times until 
the individual cycles of the wave appear, as shown in the figure below. 

 
  
Step 8 The diagram above clearly demonstrates the effect of phase inversion on 

a sine wave. To audibly perceive this effect, it is recommended to silence 
a track by activating the Mute button found in the Track Control Panel. 
This action will enable a distinct auditory recognition of the track. To 
exclusively listen to track 1, individuals should mute track 2 and then 
press the Play button. Subsequently, track 1 should be muted while 
deactivating the Mute button on track 2. At this point, individuals can 
independently play track 2. After playing these two tracks separately, 
users will perceive that both waveforms sound the same 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

30

Teaching and Learning in Communication Sciences & Disorders, Vol. 7 [2023], Iss. 3, Art. 4

https://ir.library.illinoisstate.edu/tlcsd/vol7/iss3/4
DOI: 10.61403/2689-6443.1284



 
 

 
 

Appendix C 

 

Demonstration of missing fundamental frequency concept 
 

 Step 1 As shown in previous appendices (A and B), generate 4 sine waves of 
frequencies 250 Hz, 500 Hz, 750 Hz, and 1000 Hz of amplitude 0.2 and 
duration 2 s. After completing these steps, your Audacity window will resemble 
the figure below. 

 
 

Step 2 Select all tracks by choosing Select > All 
Step 3 For mixing all the selected four tracks and creating a complex periodic 

waveform with the fundamental frequency, choose Tracks > Mix > Mix and 
Render. A new single waveform will appear on the audacity window, as 
depicted in the figure below. To save this track as a single file, navigate to the 
Menu Bar, select "File," then proceed to "Save Project As." Following this, 
designate a preferred location on your personal computer to save the file. It is 
advisable to name the file "with the fundamental frequency" while saving it as 
an Audacity project. 

 
 Step 4 Use the existing window of Audacity and select Edit > Undo Mix and 

Render to return to the original four harmonics/waveforms.  
Step 5 Select and delete the track of 250 Hz. After deleting the 250 Hz track, 

the Audacity window will have only three waveforms (waveforms of 
500, 750, and 1000 Hz), as shown in the figure below. 
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Step 6 Select all three tracks by choosing Select > All 
Step 7 For mixing all the selected three tracks and creating a complex periodic 

waveform without the fundamental frequency (i.e., 250 Hz), choose Tracks > 
Mix > Mix and Render. A new single waveform similar to step 3 will appear on 
the audacity window, as shown in the figure below. To save this track as a 
single file, navigate to the Menu Bar, select "File," then proceed to "Save 
Project As." Following this, designate a preferred location on your personal 
computer to save the file. It is advisable to name the file "without the 
fundamental frequency" while saving it as an Audacity project. 

 
  
Step 8 From the Menu bar, select File > Open and open the file "With 

fundamental frequency." By this stage, both files (i.e., “with the 
fundamental frequency” and “without fundamental frequency”) should 
be open. 

Step 9 Copy the wave "Without fundamental frequency" (by selecting Edit > 
Copy), then go back to the view of "With fundamental frequency," and 
finally paste the wave (by clicking Edit > Paste) "Without the 
fundamental frequency" below the wave "With fundamental frequency." 
Thereafter, press the Zoom In button multiple times until the individual 
cycles of the waves appear, as shown in the figure below. 
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Step 10 The figure above clearly shows that the period and wavelength of both 

waveforms are the same. To exclusively listen to the first track (“with 
fundamental frequency”), mute track 2 (“without fundamental 
frequency) and then press the Play button. Subsequently, track 1 should 
be muted while deactivating the Mute button on track 2. At this point, 
track 2 can be played independently. After playing these two tracks 
separately, users will perceive that both waveforms have the same 
pitch. 
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