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Abstract

Dashboards allow managers to interact with data, asking “what if” questions and looking for patterns.
This topic is typically mentioned in information systems courses; however, many students will not have
experience with developing dashboards or using them to answer business questions. The purpose of
this assignment is to provide students with hands-on experience creating a dashboard using Excel’s free
Power View add-in. The exercise is based upon a real case. Students are provided anonymized
registration data for participants at the Super Saturday Series (S3), an outreach event for middle and
high school girls. The dashboard is designed for the S3 Directors to answer questions such as: How
much money was collected? Which day and time of day was the most popular for registrations? How
many participants attended each date? Which school systems had the highest number of attendees?
Lowest number of attendees? Step-by-step instructions demonstrate how to add different types of
visualizations, including line charts, bar charts, and tables. Students will customize their dashboard by
selecting a theme and inserting an image. After completing the dashboard, students will use it to answer
business questions. This assignment is suitable for undergraduate students taking a computer literacy,
introductory information systems, or data analytics course. Although some basic proficiency in Excel is
required, students do not need any prior experience in Power View to complete this assignment.
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1. BACKGROUND INFORMATION gender, ethnicity, school, and desired registration

date. The online system documents the date and

Super Saturday Series (S3, www.ggc.edu/s3) is a
fun, hands-on workshop series that exposes
middle and high school girls to technology and
science in a friendly college setting. S3 utilizes
interactive games and experiments to pique girls’
interest in technology and science. S3 also
provide girls with an exciting opportunity to
interact with positive, professional role models.
Our community, comprised of students and
volunteers, promotes learning in an engaging way
in order to lay a positive science and technology
foundation that attendees’ current education may
lack.

Parents enroll students in S3 using an online form
and enter personal information such as
participant’s name, email address, grade level,

time that parents register, and S3 staff keep track
of payments made.

The S3 Directors have provided you an
anonymized version of registration data for the
February 21st and February 28th sessions. To
assist them, you will create a dashboard within
Excel using Microsoft’s Power View add-in.

2. SETUP IN EXCEL
1) Open Excel 2013 or 2016.

2) Go to File > Options > Add-Ins
3) In the Manage box, click COM Add-ins - Go.
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s
e \ .L& View and manage Microsoft Office Add-ins.
Formulas =
Proofing Add-ins
Save Name ~ Location Type o
Language Active Application Add-ins |
5 Acrobat PDFMaker Office COM Addin C\...aker\Office\)64\PDFMOfficeAddin.dll  COM Add-in
Aivanced Microsoft Office PowerPivot for Excel 2013 C:\...dd-in\PowerPivotExcelClientAddindll  COM Add-in
Customize Ribbon ‘ Microsoft Power Map C:\..review for Excel\ExcelPluginShellExt.dll  COM Add-in
| Microsoft Power Query for Excel C:\Windows\System32\mscoree.dll COM Add-in
Power View C:\..Add-in\AdHocReportingExcelClient.dll  COM Add-in

m

Inactive Application Add-ins

Analysis ToolPak C\.ficel5\Library\Analysis\ANALYS32.XLL  Excel Add-in
# 2 ‘ Analysis ToolPak - VBA C:\...el5\Library\Analysis\ATPVBAEN.XLAM  Excel Add-in
Date (XML) C:\...icrosoft Shared\Smart Tag\MOFL.DLL  Action
Euro Currency Tools C:\..ice\Officel 5\Libran AEUROTOOL.XLAM  Excel Add-in
Inquire C:\...ft Office\Officel 5\DCF\NativeShim.dil  COM Add-in
Microsoft Actions Pane 3 XML Expansion Pack
Solver Add-in C:\...fficel5\Library\SOLVER\SOLVER.XLAM  Excel Add-in 5

Document Related Add-ins
No Document Related Add-ins -
Acrobat PDFMaker Office COM Addin
Publisher: Adobe Systems, Incorporated
Compatibility: No compatibility information available
Location: C:\Program Files (x86)\Adobe\Acrobat 10.0\PDFMaker\Office\»x64\PDFMOfficeAddin.dll

Description:  Acrobat PDFMaker Office COM Addin

Manage: | EETIETIETSN ] [ Go. #3

Figure 2.1: Managing Add-Ins

r
COM Add-Ins

Add-Ins available:

|,Tij Acrobat PDFMaker Office COM Addin

sl QuiTe

lg icrosoft Office PowerPivot for Excel 2013
|

ower View

Location: C\Program Files (86)\Microsoft Office\Officel5\ADDINS\Power View Excel Add-in\AdHocReporting
Load Behavior: Load at Startup

Figure 2.2: Selecting Add-ins

4) On the screen that appears, check the boxes

for 5) In Excel 2013, Power View should
e Microsoft Office Power Pivot in automatically appear on the Excel ribbon
Microsoft Excel 2013/2016 under the Insert tab after completing these

Power View steps.

Then, Select OK
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HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW POWER QUERY POWERPIVOT

(R [Fe=! ===! ' | B & - - = - k- —
| 2 B O ag m (WSt 2 . w- i | 22 W
AL - - v - -
PivotTable Recommended Table Pictures Online > My Apps ~ E Recommended . ' pivotfbat  Power p Line
PivotTables Pictures @+ 7 Charts L RS o View
Tables lllustrations Apps Charts Reports wer Map 5

Figure 2.3 Excel Insert Tab with Power View

$3-Input-Data-In-Excel-ONLY - Copy - Excel

Home Insert Pagelayout Formulas Data Review View  Add-ins [EJOVCVEWSN ACROBAT  PowerPivot Team  Q Tell me what you want to do.. Nannette Napier S Share
e X <Al ™Y R & =5 E (==
- 222 . ] Is] =] = B~ ]
Cop AlText Size ~ ~ =
Paste Undo Redo Themes . Set Image Transparency Refresh Relationships « Fitto Field Filters Power Text Picture Arrange
. {iBackground Image ~ Position < Window List Area  View Box
Clipboard Undo/Redo Themes Background Image Data view Insert Arrange ~
X . Filters ¢ x Power View Fields x =
S3 Registration — Feb 2015 . e
» BT Participants
Timestamp Amount Peid  Student Home City  Student Home Zip  Current Grade Level  Gender
172015 20 Loganville 30052 8th Female
17/2015 20 Conley 30288 Sth Female
1/18/2015 20 Lawrenceville 30044 7th Female
1/18/2015 20 Lawrenceville 30045 Sth Female
1/18/2015 20 Lawrenceville 30043 Tth Female
1/18/2015 20 Lawrenceville 30043 10th Female
182015 20 Lawrencevile 30044 0th Female
1222015 20 Loganville 30052 7th Female
/222015 20 Sugar Hill 30518 6th Female
/232015 20 Buford 30519 Tth Female
1/25/2015 20 Lawrenceville 30045 Tth Female
1/26/2015 20 Buford 30519 6th Femaie e LTI TER
1262015 20 Bufrd 30519 7th Femaie FIELDS
272015 20 Lawrenceville 30045 7th Female
1272015 20 Suwanee 30024 6th Female
< apme 9 Chrne Wi i 20n97 2 [,
| Participants | Power Viewl ® ] »
Ready = mE = ] + 100%

———— | m—— R L p—

Figure 3.1 Power View with Updated Title

In Excel 2016, you should follow these indicating that 101 girls registered as
instructions to customize the ribbon to make participants across the two dates:
Power View appear: Feb 21 and Feb 28.
https://support.office.com/en- e Personal information captured (such
us/article/Turn-on-Power-View-in-Excel- as name, home address, and email)
2016-for-Windows-f8fc21a6-08fc-407a- has been removed.
8a91-643fa848729a?ui=en-US&rs=en-
US&ad=US. 3) With your cursor inside the Excel table, open
Power View (Insert tab > Power View). Please
6) Close Excel be patient as it may take a minute or two to
load.
3. GETTING STARTED 4) When the Power View screen comes up,
replace “Click here to add a title” with “S3

1) Download S3-Input-Data.xlsx and save to a Registration — Feb 2015.” So far, your screen
known location. should look like this:

2) Open the file in Excel. You should see the 5) Delete the default table that was provided by
Participants  worksheet which contains selecting the outside edge of the table. Then,
registration data organized as an Excel table. click Delete button.

e Each row provides information about 6) Save your work.

one participant in the S3 program. As
you can see, there are 101 rows
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4. ETHNICITY TABLE

1) Create a new visualization by selecting the
following two fields under Participants as
shown in Figure 4.1:

e Ethnic Origin
e Amount Paid

Power View Fields X
ACTIVE AlLL

4 Participants
| E Amount Paid
Current Grade Level
Current School
Date Attended
Day Abbrev
Z Day Applied
Day Mame
bl Ethnic Origin
Gender
% Hour Applied
Month Abbrev

" hAnnth Annliad

Drag fields between areas below:

TILE BY

FIELDS
Ethnic Crigin -
¥ Amount Paid -

Figure 4.1 Fields for Ethnicity Table

Before:

Ethnic Onigin Amount Paid

African American/Black 880
Hispanic 140
Cther 410
Prefer not to answer 140
White 360
Total 1930

2)

3)

4)

5)

Change the format of the values in Amount
Paid by doing the following (Figure 4.2):

e Select one of the values under the
“Amount Paid” column.

e On the Design tab in the Number
group, change the format from
General to Currency.

Click on the “Amount Paid” heading to sort
the data. The data should appear in
descending order by amount paid.

Above the chart, insert a Text Box to use as
a title:  “Participants by  Ethnicity”.
HINT: The Text Box is on the Power View tab
in the Insert group.

Resize the textbox as needed

Participants by Ethnicity
Amount Paid ™
£880.00
$410.00
$360.00
$140.00
$140.00
$1,930.00

Ethmic Crigin

African American/Black
Other

White

Hispanic

Prefer not to answer
Total

Figure 4.3 Final Ethnicity Table

After:

Ethnic Ongin Amount Paid

African American/Black
Hispanic

Other

Prefer not to answer
White

Total

§880.00
§140.00
£410.00
£140.00
§360.00

$1,930.00

Figure 4.2 Impact of Format Change
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1)

2)

5. COLUMN CHART

Click on a blank part of the existing Power
View canvas to indicate you want to create a
new visualization.
Select the following two fields under
Participants as shown in Figure 5.1:

e Short Date Attended

e Timestamp

Power View Fields x
ACTIVE ALL

|:| Month-Day Registered

4)

the count of participants).To make this
change:
e Under FIELDS, click on Timestamp
e Select “"Count (Not Blank)”
Both the field description and actual
visualization should change (as shown in
Figure 5.3 below).

FIELDS

Short Date Attended  Count of Timestamp
Short Date Attended 2 17 “
ort Date Attende 2/28/2017 61
# Count of Timestamp Total 101

Figure 5.3 Attendance Count by Date

5) Switch this visualization to a Stacked Column
[ ] = Numeric Grade Chart. HINT: Design tab > Column Chart >
[ ] school category Stacked Column Chart
[] school System 6) Remove the title from this visualization
¥ HINT: Layout tab - Title > None
Short Date Attended 7) Show Data Labels
[] student Home City HINT: Layout tab - Data Labels - Show
|:| ¥ Student Home Zip 8) Resize as desired
[] Time of Day 61
Timestamp - 60
|:| Type of School
DE Week day Applied 30
|:| ¥ Year Applied
40
Drag fields between areas below:
TILE BY 30
20
FIELDS
Short Date Attended - 10
Timestamp -
a
Feb 21 Feb 28
Figure 5.1 Fields for Column Chart
gure 5 elds for Colu Cha Figure 5.4 Final Column Chart
FIELDS
Shart Date Attended - 6- BAR CHART
Timestamp -
Remove Field 1) Click on a blank part of the Power View
Do Not Summarize canvas to indicate you want to create a new
Count {Not Blank) l visualization.
Count (Distinct) 2) Select the following two fields under
Show items with no data Participants
e Day Abbrev
. . e Time of Day
Figure 5.2 Change to Count Timestamp « Timestamp
3) The table created shows each individual
timestamp. Instead, we want to show the
Count of each timestamp (which represents
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. : 3 4) Switch this visualization to a Stacked Bar
Power View Fields Chart
ACTIVE ALL 5) Remove the title from this visualization
e s 6) Show Legend at Right
— [a] 7) Show Data Labels
Day Abbrev 8) Insert a Text Box to use as a title: “What days
|:| ¥ Day Applied and times have most registrations?”
|:| Day Mame
[ ] Ethnic Origin — —
D EECLE Day Abbrev g

|:| ¥ Hour Applied
[ ] Month Abbrev

# Count of Tipesterrr—) T
[ ] = Month Applied :

Remove Field
|:| Month Mame

Time of Day -

|:| Fonth-Day Registered Do Not Summarize
[ | = Mumeric Grade v | Count (Not Blank)]
|:| School Category | Count (Distinct)

|:| School System
[ ] short Date sttended
[] student Home City

Figure 6.2 Change to Count of Timestamp

[ ]z student Home Zip 9) (S:\r/]vitch this visualization to a Stacked Bar
art

Time of Day o 10) Remove the title from this visualization

Timestamp 11) Show Legend at Right

|:| Type of School [+] 12) Show Data Labels

13) Insert a Text Box to use as a title: “What days
. . and times have most registrations?”
Figure 6.1 Fields for Bar Chart Feel free to resize and move the visualization

on the canvas

3) As before, change Timestamp to Count of
Timestamp

Time of Day
A
P

What days and
times have most
registrations?

L 5 1a 15 20 25
Figure 6.3 Final Bar Chart
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1)

2)
3)
4)

1)

2)
3)

7. MATRIX TABLE

Create a new visualization using the following
fields

a. School Category

b. School System

c. Timestamp
Change Timestamp - Count of Timestamp
Switch the visualization to Table > Matrix
Resize and move so there is enough room for
the data about School systems and Count of
Timestamp to appear on the dashboard

8. LINE CHART

Create a new visualization using the following
fields

a. Month-Day Registered

b. Timestamp
Change Timestamp - Count of Timestamp
Switch the visualization to Line Chart
Remove the title

5)

1)

3)

4)

5)

Insert text that can be used as a title: “Apps
per Day”

9. FINISHING TOUCHES

Arrange all the visualizations within the
Dashboard. It will be a little crowded, but you
can always use the “pop out” accelerator to
see a particular visualization full screen.

Insert picture of your school logo onto the
dashboard [HINT: Power View tab - Picture]

Change the theme of the dashboard [HINT:
Power View tab > Themes]

Change the background to something of your
choice [HINT: Power View tab - Background]

Rename the worksheet from “Power View 1”
to “S3 Dashboard”

When done, check your work. Save your file.
Then, submit.
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