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What This Guide Covers

This guide has been designed to help users interested in disseminating information through the Web to get started as
quickly as possible. It is not meant to be an exhaustive description of all features available in FrontPage, nor will it

cover all of the Web technologies that are currently available.

This guide has been designed for use in the two instructional workshops offered by the RP Group (the Research and
Planning Group of California community colleges) in November 1997. It can also be used alone as a resource for

teaching yourself to use FrontPage.

Through the instructional workshop and the use of this guide you will be introduced to the following topics:

Converting MS Office documents to HTML
Understanding the Role of FrontPage in Web Development
Creating a FrontPage web
Opening an existing FrontPage web
Creating, editing and previewing web pages
Creating links between and within web pages
Inserting and formatting images
Linking images
Creating, modifying, and enhancing tables
Verifying Links In FrontPage
Using Help in FrontPage
Publishing your web site

This guide will also provide you with information related to managing your web site and additional information related

to the use of FrontPage:

Do I really have time to build and maintain a web site
Promoting your web site
Policies for publishing on the web
Resources for web site development
Setting up FrontPage in Windows NT and Windows95 operating system environments
Hardware and software requirements related to server vs. site administration
A glossary of terms related to the guide's use

Note: This guide can be downloaded directly from the Los Rios Community College District IR
Web site

http://irweb.do.losrios.cc.ca.us
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Converting MS Office documents to HTML documents

As you begin planning for the use of FrontPage, we recommend that you start working in an MS Office environment.
Because Microsoft products offer excellent integration to one another, you will begin ahead of the game in FrontPage
by using the MS Office Suite. Moreover, all of these products have a similar look to them, providing ease in use as you
move from one Microsoft application to another.

Each of the applications in MS Office comes with a wizard for translating a document to HTML, the programming
language used to create web pages. In order to use these features, a web conversion module for MS Office must be
installed. You can install the module by selecting Customized Setup and then selecting the Web Page Authoring
(HTML) option during the MS Office setup process.

When you convert an MS Office document, the steps you take to convert it are slightly different depending on the
application. However, for all MS Office documents, the first step is to select Save as HTML from the File menu. A
dialog box will appear prompting you to enter information the wizard needs to convert the document into HTML.

For example, to convert an MS Word document, simply select Save as HTML from the File menu (See Figure 1).
Next, specify the location where the HTML document is to be saved and select OK. The wizard converts the text and
formatting in your document into HTML format and converts all graphic objects, like charts and pictures, to a GIF
format, one of the two allowable graphic image file formats available on a web page. Each of the graphic objects is
given a generic name that you will want to rename more specifically. Any HTML editor or web development tool can
be used to open the converted document. Note that you can edit the HTML document in MS Word. However, you will
not get the same functionality that you would if you were to edit the same document in a FrontPage environment.

Figure 1
Saving a document as HTML
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Special Note: If a document contains any small graphic objects like pictures or charts, the conversion process may
reduce the quality of the picture or chart. Under these circumstances, be sure to enlarge those objects to a suitable size
before performing the HTML conversion.
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Understanding the Role of Front Page in Web Development

What is Front Page?

Front Page consists of a set of applications for web site design, administration, and content creation. The guts of
Front Page are the Front Page Explorer and the Front Page Editor. Web site design and administration are performed
through the Front Page Explorer. The Front Page Editor is used for web page creation. Front Page also comes with two
other programs Image Composer and Web Publishing Wizard. Image Composer is an application for creating and
enhancing graphic objects. The Web Publishing Wizard is an FTP program for automating the transfer of web pages to
a web server that does not support Front Page. We do not, however, recommend using the Web Publishing Wizard,
because there are many other FTP programs that work much more efficiently (see discussion in the "Publishing Your
Web Site" section called "Publishing when Front Page Extension is Not Installed").

Front Page Explorer

The Front Page Explorer is essentially a web administration application that allows you to manage, and delete entire
webs. With Front Page Explorer, you have an overall picture of your entire Web. From the FrontPage Explorer, a user
can design and maintain a web site graphically (See Figure 2). There are two different perspectives that the user can

see the HyperLink View and the traditional Folder View. The HyperLink View gives a view of a particular web
page along with all the links to which the web page is pointing. The Folder View gives a hierarchical view of where the
files are stored on your web site.

Figure 2
FrontPage Explorer in HyperLink View
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Through FrontPage Explorer, you can create new FrontPage web sites and delete old ones. Think of FrontPage Explorer
as the FrontPage file manager. The files and folders on the web site are manipulated just like normal files and
directories. Probably the only difference is that when you move or rename files within the FrontPage Explorer
environment, all web pages that link to the affected file are automatically updated. Another indispensable tool is the
link verification tool. The link verification tool goes through the web pages on the web site and verifies whether links
are or are not broken. Traditionally, a web administrator would have had to go through each web page and manually
verify a link. As you can imagine, this can be tedious if your web site is large.
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Front Page Editor

The component of Front Page that is used to create and edit individual web pages is called the Front Page Editor. Using
the Editor, you can enter text, format it, format the entire page itself, insert images on the page, create links, insert
tables, and the like. It works much like any word processor in that it enables you to type text, copy text from other
documents, open and save files and format text as you do with word processors.

With Front Page Editor, you can enter and format text, insert images, create links, insert tables, and more (See Figure 3).
Traditionally, HTML content was developed using simple text editors such as MS Notepad. With Front Page, much of
the complexity associated with HTML coding is eliminated, because creating content in Front Page is much like writing
with a word processor. In fact, much of the functionality, such as spell checking and thesaurus (which exists in most
word processing programs) also exists in Front Page Editor.

Figure 3
Front Page Editor
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Creating a Front Page Web

Before you can create web pages using Front Page, you should establish a web site to store the pages. By default,
Front Page creates the web site called "root web" when you install Front Page. As its name implies, the "root web" is the
highest level on your web site. If users were to browse to your machine and just type the address of your machine, they
would see the default page of your root web. When you create a new FrontPage web, a folder with the name of the

new web is created under the folder of the root web. Users browsing the web on your workstation would not be able to
distinguish the difference between different FrontPage webs, such as your "staging" web (sometimes referred to as
"working" or "testing"), where you edit and update, and your "published" web. However, FrontPage software treats
each FrontPage web as an independent web. FrontPage Explorer doesn't see any of the content in the other FrontPage
webs that you may create. The advantage of this is that you can create multiple copies of your web site in different
FrontPage web files for the purpose of testing. You can perform the testing on a test web without affecting your live

web site.

When FrontPage Editor first starts, a dialog box appears with a number of choices for the user to select (see Figure 4).

From the dialog box, the user can open an existing web or create a new web.

Figure 4
FrontPage Start Dialog Box
Getting Started with Microsoft FrontPage
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Select the Blank FrontPage Web option and click OK. Next, a dialog box will appear, prompting you to enter a name
for the new web (see Figure 5). Enter the name of the web server in the Web Server or File Location drop-down text
box. Note that if you enter the keyword "localhost" it is referring to the workstation that you are currently using.
Otherwise, the convention for referencing a web server is the same as if you were using a web browser; examples
related to Los Rios Web sites include www.losrios.cc.ca.us, irweb.do.losrios.cc.ca.us, etc.... Enter an appropriate
name for the new web site and select OK. Once FrontPage has finished creating the new site, you will see the
FrontPage Explorer. When a new web is created in FrontPage, a default page is created automatically. The name of the
default page (a web site's opening "Home" page) differs depending on what you specify as the name of the default page
for the web server. Common default names are: default.htm, default.html, index.htm, index.html, etc.... To close a
FrontPage web, select Close FrontPage Web or Exit from the File menu.
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Figure 5
Dialog Box Prompting for Name of New Web Site
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Another option after opening Front Page Explorer, is to select New, Front Page Web from the File menu. A dialog box
appears, giving you options to choose from a list of web site templates or wizards as well as a choice to create a normal
web site (See Figure 6). Select the Normal Web and click OK. From this point on, you take the same steps that you
would after selecting Blank FrontPage Web.

Figure 6
New FrontPage Web Dialog
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Opening an Existing Front Page Web

To open an existing web site, open Front Page Explorer and select Open Front Page Web from the File menu.
Otherwise, open Front Page from your Start Taskbar in your Windows95 or NT4.0 operating system. When Front Page
first opens a Start dialog box appears. From it, select Open Existing Front Page Web and a new dialog box appears

(See Figure 7). Enter the address or DNS (domain name) of the web server in the Web Server or File Location drop-
down list box; select List Webs. If the web server is on the same machine you are currently using, type in "localhost"
in the Web Server or File Location list box, then select List Webs; a list of available FrontPage webs will appear in
the text box below. Select the FrontPage web you want to open and click OK.

Figure 7
Dialog Box for Opening a FrontPage Web

Open FrontPage Web 1E3

Web Server or File Location:

irweb.do.losrios.cc.ca.u::

r: Connect Using SSL

FrontPage Webs:

List Webs

or

Cancel

Help

BEST COPY AVAILABLE

9

Los Rios Community College District Office of Institutional Research, Sacramento, California p.8

http://irweb.do.losrios.cc.ca.us



Creating, Editing and Previewing Web Pages in Front Page

To create a new web page, you must first activate the Front Page Editor. The simplest way to open the Front Page Editor
is to click on the Front Page Editor icon (see Figure 8). When the Front Page Editor appears, select New from the File
menu to create a new web page. A dialog box will appear, prompting you to select the type of page to create (see
Figure 9). Note that there are many different selections to choose from. The first choice is Normal Page, which is a
blank web page. The rest are templates that comes with FrontPage. Select the Normal Page option and click OK.

Figure 8
FrontPage Editor Icon
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Figure 9
Dialog Box Prompting You to Select the Type of Web to Create
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After creating a new web page, it is a good habit to give it a meaningful title. The title of the web page is whatpeople
see when they bookmark it in their Web browser for easy future reference, so it is important to give it a name that they
can associate easily with your web site and the specific web page. To specify a page title, background or hyperlink
color, select Page Properties from the File menu. A tabbed dialog box will appear with the General tab selected (See
Figure 10). This is where you can specify the title of a web

I!
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Figure 10
Tab Dialog Box for Specifying Page Title
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The next item to specify would be the background color and hyperlink color of your web page, so that it is consistent
with the rest of you web site. To specify the background and hyperlink color, select the Background tab. With the
Background tab selected, you can modify the background color, the text color, and the hyperlink color by selecting the
available options in each of the drop-down lists (See Figure 11).

Figure 11
Tab Dialog Box Specifying Background and Hyper link Color
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After changing the background color and hyperlink color, you should save the web page. To save a web page, select
Save As... from the File menu. A dialog box will appear prompting the user to specify the filename of the web page
(as shown in Figure 12). After doing so, select OK. Note that you can also specify the title of your web page here.

Figure 12
Dialog Box for Saving a Web Page
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Now that you have created a new web page, it is time to put content into it. Notice the similarity of the FrontPage
Editor to MS Word and other MS Office software (see Figure 13). To create content, all you have to do is start typing
as if you were in a word processor environment. There are, however, a couple of basic limitations. First, the default
spacing when you hit the Enter (return) key is double spacing. To get around this, hold down the Shift key and then
the Enter key to create single spaces between lines. Second, you can only create one space between each word; please
refer to the section entitled "Creating, Modifying and Enhancing Tables" to learn how to get around this formatting
problem. To format text, select the text as you would in a text editor, such as MS Word and choose one of the
formatting options available through the Format menu item or choose one of the formatting buttons available.

Figure 13
Formatting Buttons/Icons in Front Page Editor
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To preview your newly created web page, click on the button/icon that will put you into the browser (see Figure 13
above). You will now see what your web page looks like to your Internet viewers.
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Creating Links between and within Web Pages

One of the most common tasks in developing web pages is creating links to other web pages or elements within web

pages. With Front Page it is very easy. With the document opened in Front Page Editor, you can create a link from a
text statement in Front Page by simply selecting (highlighting) the text that you want to link. Next select Hyper Link
from the Insert menu. A dialog box will appear (see Figure 14) with the Current Front Page Web tab selected. The
dialog box gives you an option to link the text to: a web page that is already opened in the Front Page editor; a web

page in the current Front Page web where you are working; a World Wide Web page outside the current Front Page web;

or a new web page.

Figure 14
Dialog Box for Specifying Hyper link Properties
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To link to an opened web page, select the Open Pages tab (see Figure 15). The tab will display a list of available web

pages that you already have opened to which you can link. Notice that the web pages are referenced by their title and
not by the file name. Select the desired page to link to. If you want to link to a bookmark in the target page, click on
the Bookmark drop-down list and select the available bookmark (a bookmark is a marked location within a web page
that is often used for quick navigation within a page that has a great deal of text). Finally, click OK. Note that you may
also want to specify the target frame where the linked page will appear. This setting is important only if you areusing
HTML frames to develop your web site. In general, you can ignore the Target Frame setting.
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Figure 15
Dialog Box Linking to an Opened Page
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To link to a page in the current Front Page web, select the Current Front Page Web tab (see figure 16). If you know
the name and path of the web page, you can type it in the Page text box. Otherwise, click the Browse... button. An
Explorer view of the root of your Front Page web is displayed. Browse to and select the target page to which you want
to link and click OK. You are now back in the Edit Hyper link dialog box. Notice that you can also specify the
bookmark or target frame here, as well, if you wish to link directly to either of these components of a web page.

Figure 16
Dialog Box for Linking to a Web Page within the Current Front Page Web
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To link to a web page outside the current FrontPage web, select the World Wide Web tab (see figure 17). If you know
the URL of the document, you can type it in the URL text box. Otherwise, click the Browse... button. This will
activate Microsoft's Internet Explorer, the default web browser. Browse to the document you want and then switch
back to the FrontPage Editor. Notice that the URL of the document is automatically placed in the URL text box. Click
OK to complete the linking process. Also note that if you already did have your browser open while you were working .

in FrontPage, the URL to which your browser was currently pointing would appear in the URL text box.
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Figure 17
Dialog Box for Linking to a Web Page outside the Current Front Page Web
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To link to a new web page, select the New Page tab (see Figure 18). Specify the title of the web page in the page title
text box. Next, specify the file name of the new page in the Page URL text box. Notice that you have the option of
editing the new page immediately or putting the item in the task manager. For the purpose of this document during our
training session, let's create the new page immediately. Click OK and another dialog box appears, prompting you to
specify the type of page to create. This is the same dialog box that appears when you create a new web page in the
FrontPage Editor. Select the Normal Page option and click OK. You are now back in the Editor with the newly
created web page opened in FrontPage Editor.

Figure 18
Dialog Box for Linking to a New Web Page
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Inserting and Formatting Images

Often, you will want web pages that you create to contain graphical objects. These graphics make the web page more
visually appealing. They are also used to help convey an idea that is hard to put in text format, only. For example, it is
easier for Internet viewers to understand the meaning of a list of numbers when they are visually displayed in some type
of chart, rather than only discussed through text.

To insert an image in Front Page, position the cursor in the location where you want to insert the image. Next, select
Image from the Insert menu. An Image dialog box appears, giving the user the option to get the image from the
current Front Page Web, from the clip art gallery, or from another location outside the current Front Page web.

To insert an image from the current Front Page web, select the Current Front Page Web tab (see Figure 19). The tab
will display a list of available images. Navigate to and select the desired image. Click OK to return to the Front Page
Editor.

Figure 19
Dialog Box for Inserting Images from the Current Front Page Web
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To insert an image from the clip art gallery, select the Clip Art tab (see Figure 20). Notice the Category list box.
Select the category of images that you want. Finally, select the image and click OK.
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Figure 20
Dialog Box for Inserting Images from the Clip Art Gallery
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To insert an image from outside the FrontPage web, select the Other Location tab (see Figure 21). If you know the
name and path of your image, you can type it in the From File text box. Otherwise, click on the Browse... button to
locate the desired image.

Figure 21
Dialog Box for Inserting Images Outside of the Current FrontPage Web

Image ci
Current FrontPage Web Other Location

CF. From File

C_ From Location

Clip Art 1

Browse...

OK Cancel Help
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Now that you have inserted an image, it is time to save the image into your Front Page Web page. Select Save from the
File menu. Front Page detects that this is a new image and will prompt you to save the image. Front Page will suggest a
file name for the image, and if you are happy with the name, click Yes. Front Page will prompt you for all the new
images in the web page. If you want to save all the new inserted images, click Yes to All (see Figure 22). If FrontPage
detects that you are trying to save an image with the same name as one that already exists, it will give you the option to
either replace or use the existing image (see Figure 23).

Figure 22
Dialog Box for Saving Images, FrontPage Did Not Detect Image with Identical Name

,x

Save this image to the current FrontPage web?

Save as URL: Black Oval39D.alf

Yes 1 I Yes to All No
--=

Cancel Help

Figure 23
Dialog Box for Saving Images; FrontPage Detected Another Image with the Same Name

Save Image to FrontPage Web

Save this image to the current FrontPage web?
(Saving will replace the existing image with the same name, and may affect other pages
in the current web that include the same image.)

Save as URL: JIMMIE

Replace 1 Yes to All Use Existing Cancel 'Help

Now that the images are saved into the FrontPage web, you might want to format the layout of the image. You move
an image in FrontPage in the same way that you would move an image in a word processing document. The easiest
way to move an image is to highlight the image and select Cut in the Edit menu. Next, position the cursor at the
location to where you want to move the image and select Paste from the Edit menu.

To align an image, select the image. Right click on the mouse and choose Image Properties. Select the Appearance
tab (see Figure 24). Select the desired alignment type by clicking on the Alignment drop-down list. Click OK to exit
the Image Properties dialog box.
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Figure 24
Dialog Box for Modifying the Appearance of an Image
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Linking Images

Linking images in Front Page is very similar to linking text. One way to link an image is to select the image, then right
click on the mouse and choose Image Properties. Select the General tab. If you know the name and path of the web
page, you can type it in the Location text box. Otherwise, click on the Browse button (See Figure 25). A Create
Hyper link tab dialog box appears, giving the user the choice of linking to a web page that is already opened in the
Front Page Editor, to a web page in the current Front Page web, to a page outside the current Front Page web, or to anew
web page (See Figure 26). From this point on, it is exactly like creating a text link (please refer to the previous section
of this guide called "Creating Links between and within Web Pages" for details). When you click OK in the Create
Hyper link dialog box, it brings you back to the Image Properties dialog box. Click OK on the Image Properties
dialog box to complete the linking process. Another way of linking an image is to select the image and then select
Hyper link from the Insert menu. Again, this is exactly the same way you would create a text link.

Figure 25
Dialog Box for Specifying Hyper link for an Image

General Video Appearance

Image Source:

bannera. I"; Browse...

7 Type,

GIF f It; nepwent

r: interlaced

Edit...
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Text:
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Location: I Browse...

Target
Frame: J.

'X

Extended...

OK Cancel 1! Help
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Figure 26
Dialog Box for Specifying Hyper link Properties

Open Pages Current Front Page Web World Wide Web I New Page

cage:

Browse...

Bookmark:

Target Frame: I
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OK I Cancel 1 Clear Extended... Help
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Creating, Modifying and Enhancing Tables

In addition to hyperlinks, tables are probably one of the most commonly used element in an institutional research web
page. They are useful for putting data in a format that is easier to view and understand. Tables also play a very
important role in laying out a web page. A web developer often takes advantage of tables to overcome the layout
limitation that currently exist with today's web standard, such as only being able to create one space between each
word.

The easiest way to insert a table is to select Insert Table (see Figure 27) from the Table menu, after which an Insert
Table dialog box appears, prompting the user to enter information about the table. From the Insert Table dialog box,
specify the number of rows and columns you want in your table and click OK.

Figure 27
Dialog Box for Inserting a table in FrontPage Editor

Insert Table Ei

--Size

Rows:

Columns:

1
OK

Layout

Alignment: I (default)

Border Size:
JB

Cell Padding:

Cell Spacing: 12

Cancel

Extended...

Help

I Specify Width: 1100

r:i in Pixels

(7.,! in. Percent

Specify the number
of rows and columns
in the table

Specify the
alignment, border
size, cell padding,
and cell spacing of
the table

Specify the width
of the table

Now that you have created your table, you can add text or images to the cells in the same way you would with a word
processor. To navigate between cells within the table, you can select the cell directly, or you could use the Tab key or
the Shift Tab key.

To add more rows to the table, tab or select the bottom right corner cell of the table and hit the Tab key. You can also
select any cell in the bottom of the table and select Insert Rows or Columns from the Table menu. A dialog box will
appear, allowing you to specify the number of rows or columns to insert. Notice that you can either insert therows
below or above the selected cell.

To insert another column, select the cell next to the location where you want the new column to go. Next select Insert
Rows or Columns from the Table menu. A dialog box will appear allowingyou to specify the number of rows or
columns to insert. Select the Columns option and specify the number of columns to insert. Notice that you now have
the option to insert the column to the right or left of the selected cell.

To modify a table property, select any cell within the table. Right click on the mouse button and select Table
Properties. From the Table Properties dialog box, you can modify the border width, the background color, cell
spacing and padding, border color, and size of the table (see Figure 28). For more information on each of the options,
press Fl on your keyboard for a short description of each option.
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Figure 28
Dialog Box for Modifying Table Properties
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Verifying Links in Front Page

When you finished creating your web site, it is a good practice to make sure that all links, both internal and external, are
not broken. In general, broken links occurs when a link reference is incorrectly typed, when a web component like an
image or web page is accidentally deleted, or when the external link is either temporarily unavailable or no longer
exists. A web site with a lot of broken links is very annoying to the end user and may discourage the user from using
the site again.

One way to verify links on a FrontPage web site is to open each web page and follow every possible link, thus, making
sure each is not broken. A far easier way is to use the link verification tool that is available in FrontPage. To use the
link verification tool, select Verify Hyperlinks from the Tools menu in FrontPage Explorer. When the Verify
Hyperlinks dialog box appears, click on the Verify button (See Figure 29). FrontPage will check all the internal and
external links and will give you the status for each link.

When FrontPage finishes verifying the links, it will report on the number of internal and external broken links. In the
Verify Hyperlinks dialog box, you will see the list of links (URL). You will also see the Status and the page reference
of the link (Linked From). If the link is broken, the broken status is indicated by a red dot. If the link is not broken, its
status will be indicated by a green dot. During the verification process, if the link has not been checked yet, its status
will be indicated by a yellow dot. When the verification process is done, you can correct any broken links directly or
you can open the page that contain the link to modify it by click on the Edit Link button or the Edit Page button.

Figure 29
Dialog Box for Verifying Links
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Help is a wonderful tool to use in FrontPage, because it is context sensitive. What this means is that when you are
struggling in FrontPage Explorer or as you work on content or formatting of a Web page in FrontPage Editor, pressing
the F1 key (or by clicking the Help button) will bring up information related to where your cursor is pointed. You also
have the option to type a word or set of words to obtain helpful information. There are also very detailed indexes and
find options for you to use. If you struggle when you begin using FrontPage, do not hesitate to take advantage of Help.
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Publishing Your Web Site

If your Front Page web site is actually the live site, you don't have to publish it. What this means is that all the
modifications you have made are done on the live site. However, it is usually not a good idea to work directly on a live
site. If you work directly on your live site, more than likely, there will be mistakes made and your clients will see those
mistakes. In addition, your clients are likely to stumble upon your unfinished work. For these reasons most web sites
have a staging web site where testing is performed and new changes are reviewed and edited before being published
onto the live web site. In most cases, you will be publishing your entire web site on an ongoing basis as you add new
information and edit old information.

Publishing (Uploading Your Web Site to the Web Server)

To understand the process of publishing, a quick review on servers is necessary. When you use FrontPage, there are
two types of server situations of concern. These include servers that support FrontPage and have the FrontPage
Extension installed, and servers that do not have the FrontPage Extension installed. FrontPage Extension is used for
ease in uploading your web site to the web server. The FrontPage Extension also allows you to take advantage of the
full capabilities of FrontPage (such as WebBot components, which you will learn about in a different guide that outlines
the more advanced features of FrontPage).

Publishing when FrontPage Extension Is Installed

To publish a FrontPage web onto a FrontPage enabled server (a server where the FrontPage Extension is installed),
select Publish FrontPage Web from the File menu. When the Publish FrontPage Web appears, type in the web
server's DNS (Domain Name, i.e. the Web site's name) in the Destination Web Server or File Location text box. If
the server is on the same machine you are using, type "localhost" in the Destination Web Server or File Location text
box. If you are publishing to the root web of the destination web server, leave the Name of Destination Web Server
text box blank. If neither of these situations is the case for your Web site, specify the specific name of the FrontPage
web in the Name of Destination Web Server text box. If the FrontPage web does not exist in the destination server to
which you are uploading your web site, deselect the Add to Existing FrontPage web check box. Click OK and
FrontPage will copy the contents of your FrontPage web onto the destination server. If you are publishing to a web that
has already existed, it would only copy new or changed pages to the destination server, unless you have deselected the
Copy changed pages only check box. (See Figure 30)

Figure 30
Dialog Box for Publish a FrontPage Web from FrontPage Explorer
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Publishing when Front Page Extension Is Not Installed

If the destination server does not support Front Page, you will have to manually transfer your web site's pages to the
destination server. One way to do that is to use an FTP program; there are many FTP programs that you can use to
transfer files. An example of a popular FTP program is WS-FTP by John Junod. WS -FTP became popular because it
has a graphical user interface that makes it very easy to use. WS-FTP and other FTP software can be downloaded at
www.windows95.com for evaluation.

To upload a web site using an FTP application, you need to connect to the web server with an appropriate user account
and password. Next, browse to the directory on the web server where the web pages reside. Finally, select the files or
directories that you want to upload.

As an example, to use WS-FTP, select the appropriate profile from the Profile Name drop-down list when WS-FTP
starts up. Enter a valid user name in the User ID text box. Next, enter the password for the user account. Afterward,
click Ok to connect to the web server (See Figure 31).

Figure 31
Dialog box for selecting and configuring WS-FTP profiles
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Once you have connected to the web server, browse to the directory on the web server where the web pages reside.
Select the files or directories that you want to upload, and click on the right arrow button to upload from the local
system to the remote server (See Figure 32).

To create a new profile, click on the New button. Specify the name of the profile in the Profile Name drop-down list.
Next specify the DNS name of the web server in the Host Name text box. Afterward, click on the Save button to save
the profile.

Figure 32
User interface for WS-FTP
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Do I Really Have Time to Build and Maintain a Web Site?

This guide has probably shown you that initially developing your web site is not a complicated a task to undertake, if
you start small and begin building your site incrementally. You may, however, wonder if you have the time to maintain
a site, along with the many other tasks for which you are responsible.

We have found that making a commitment to our web site has merely changed the way that we organize and distribute
our work. Conducting research, analyzing data, writing reports, conducting research related training and building
special applications for research and data generation purposes remain the primary tasks that we undertake. However,
the dissemination of the information that we produce as a resulting from our primary work is done on our Web site.
Moreover, we have found that our web site is, by far, a much more efficient means for information dissemination than
the production of hard copy reports that are printed on high quality paper. For the most part, the dissemination of
information has become far easier for us, allowing the necessary time for the necessary web site maintenance. So we
suggest that you similarly try to think differently about how you manage your work. You will be surprised how much
more efficient the web site will be for you for distributing information to your constituencies after you have dedicated
the necessary time required for initial site development.

Promoting Your WEB Site

Efforts need to be made to promote your WEB site, both internally within your college or district to faculty, staff,
managers and board members and externally to community planners, economic developers, educators, grant writers,
business and government leaders, and, of course, to other institutional researchers.

Methods for Internal Promotion

Memos and e-mail messages announcing the availability of information on the WEB ongoing as you publish new
information, in order to get people thinking about your site as a resource

Workshops (hands-on) and live demonstrations to show what's available to a broad range of users, with explanations
about how they might use the information you provide

Methods for Promoting Your Site to the External Community on the Internet

A good way to promote your site is to first link to sites that would be useful to potential users of your site. After doing
this, send e-mail messages to the Web administrators of these sites, telling them how their site is useful to viewers of
your site. Then explain why you think your site would be useful to their viewers. Give these individuals your URL
and ask them to link to your site. Using this method, we have rarely been refused.

We have used this strategy to link to other community colleges in California and to local area university research
offices. We have also linked to some of the local WEB sites in the Greater Sacramento Area where we are
geographically located using this same approach.

There are also sites that have created links to offices of institutional research throughout the U.S. that might be of
particular interest to you as a way to promote your site nationally. Two such sites are:

Internet Resources for Institutional Research
http://apollo.gmu.edu/jmilarn/air95/offices.html

Electronic Fact Books of Institutional Research Offices on the Internet
http://ir-server. willamette.edu/factbooks/index.htrn
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Promoting your site through the Major Search Engines

A good way to begin registering your web site with the major search engines is to go to a domain registration site
known as SITE AMERICA (formerly known as register.com). You can reach this site at
http: / /www.siteamerica.com/. This site will register your Domain Name (DNS) with some of the major search engines
for free, and then you pay an additional fee to have them register you with the remaining sites.

In addition, most of the major search engines themselves have information on how you can add your site to their
database on you own. Simply go to the URL of the search engine of interest to you and follow the instructions
provided. We have followed this procedure with many of the major search engines.

Policies for Publishing on the WEB

Presently, Los Rios Community College District does not have a formal, written web policy. Informal policies have
worked effectively to date. Information that is considered sensitive is published with access to district employees, only.
Primarily, the Director of Communication and Research, who is a member of the Chancellor's Executive Cabinet,
makes decisions about this information for our district office.

There is a district WEB server, and an Institutional Research WEB server at the district level. There are college WEB
servers at each of the three Los Rios colleges. All of these Web sites are linked. Each college's Public Information
Officer makes decisions about what is published on the college WEB site.

Samples of policies of other colleges, universities and education-related and government agencies are as follow:

Portland Community College, OR
http://www.pcc.edu/cpubs/web/webpolcy.htm

Pacific Union College, CA
http://puc.edu/PUC/academics/homepageguide.html

University of Wisconsin La Crosse
http://www.uwlax.edu/InfoTech/WWW_policy.html

Virginia Department of Education
http://penl.pen.k12.va.us/go/VDOE/policy/Consolidated_Policies/wwwpub.html

Department for Internal Affairs for New Zealand
http://armpit.dia.govt.nz/homepage/owner/inet-pol/dii.htm
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Resources for WEB Site Development

WEB Resources

There is a wealth of information on WEB site development, where else, but on the WEB! Here are a few for you to
visit:

North Star (WEB) Development Center
http://www.state.mn.us/devcenter/

How To Build a Web Site
http://www.cybrzn.com/webdes.html

Microsoft's Web Site Builder's Network
http://www.microsoft.com/sitebuilder/

Graphic Resources for Web Site Design
http://Stars.com/Authoring/Graphics/Resources/

Graphic Images for Web Pages includes use of buttons, icons, and GIF animation
http://Stars.com/Authoring/Graphics/Images/

"Yahoo's" World Wide Web Directory
http://www.yahoo.com/Computers/World_Wide_Web

The National Center for Supercomputing Applications at the University of Illinois-Champaign Beginner's Guide to
HTML
http://www.ncsa.uiuc.edu/General/Internet/WINW/HTMLPrimer.html

Important considerations as you plan to build a Web Site
http://www.gimpy.com/overview.htm

Microsoft and MCI are providing free Web space for K-12 schools. Related to this, the Broward North Area Schools (in
Florida) have developed templates, tutorial, ideas and resources for building Web sites.
http://www.gate.netf--natrt/wbpg.htm

Shareware's c/net resources "Building a Great Web Site Cheap!"
http://www.cnet.com/Content/Builder/Authoring/Cheap/

Windows 95 Shareware resources automated Web Publishing Tools
http://www.windows95.com/apps/webauth.html

The Teachers.Net Web Site Handbook
http://www.teachers.net/manual/

The WWW Help Page
http://werbach.com/web/wwwhelp.html#guides

Web Development Companies

If you wish to contact companies with which you can contract to host and/or design your Web site, use one of the search
engines, such as "Yahoo!" (www.yahoo.com) to do a specific search for you. Start with the search "Web Site
Development" and you will obtain information on several companies with which you can contract.
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A Bibliography of Books on Microsoft Front Page
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Weiss, Aron. Complete Idiot's guide to Microsoft FrontPage 97. Indianapolis: Que Corporation, 1997.

Setting up FrontPage in NT and Windows95 Operating System Environments

FrontPage can be installed in Windows95 or NT4.0. It can also be installed in Win NT3.51 with service pack 5.
Where you install FrontPage depends on your need. If you are maintaining your own server, it makes the most sense to
install FrontPage onto a NT4.0 Server. NT4.0 provides the best stability and, more importantly, the security necessary
to protect your server. However, you can install FrontPage onto Win95. The only requirement is that TCP/IP is
installed. TCP/IP is the suite of protocols that provides the infrastructure for the Internet. The installation TCP/IP is a
requirement regardless of what operating system you are using. A good way to determine whether you can install
FrontPage is by determining if your workstation can browse the Internet. If it can browse the Internet, you can install
FrontPage on your workstation. If TCP/IP is not installed, please contact your Information Technology/Services
department for assistance.
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Hardware and Software Requirements Related to Server vs. Site Administration

After you build your WEB site, you will need to decide whether to upload it to your district or college WEB server or
to build and publish your web site on your own WEB server and link to your district or college site. The advantage of
managing your site on your own server is that you have more control in bringing new information onto your published
WEB site according to a schedule that you establish. When you upload your WEB site to another server, you may
sometimes deal with a schedule that is determined by someone else attempting to meet multiple requests from other
WEB clients. The disadvantage to managing your own WEB server is the extra costs required, as well as the technical
expertise necessary.

Site Administration
If you choose to administer your site, uploading to your college or district server, we recommend that you use either a
Windows95 or NT4.0 operating system. You will then need to purchase the software license agreements and the
software for Office Pro 97 and FrontPage 98. As you can see below, the cost of the software is extremely reasonable for
California community colleges through Wareforce. You can obtain current costs by going to the Wareforce Web site
http : / /www.wareforce.com/wareforce /clients /ccmisc.htm. Costs to community colleges through Wareforce as of 10/97
for these items are as follow:

Office Pro 97 (license)
Office Pro 97 (software)
FrontPage 98 (license)
FrontPage 98 (software)

$ 39.
$ 17.
$ 33.
$ 17.

Server Administration
If you choose to administer your site with your own WEB server, you will probably need an entire system dedicated for
this purpose, at least at some point in time after your web site substantially grows. When we initially brought up our
web site, it resided on our local area network.

When you begin looking at a separate system for your web server, we recommend one that will cost you approximately
$3,000. You could purchase a system that will cost you roughly $2,000 (a Pentium 133 instead of a Pentium 200). But
by purchasing a system similar to the one outlined below, you will have purchased a server that will meet your growing
needs for some time. The costs outlined below were estimated as of 10/97. Specifications are as follow:

Costs for Server Administration

Processor
Memory
Cache
Monitor
Graphics Accelerator
SGRAM
Hard Drive
Floppy Drive
CD-ROM
Case
Network Card
Keyboard
Mouse
Operating System

Software
Software

Cost Estimate

Intel 200MHz Pentium processor with MMX Technology
64MB SDRAM added
Integrated 512K Pipeline Burst SRAM Cache
EV700 17" color monitor (15.9" viewable area)
Integrated ATI PCI graphics accelerator w/ 2MB

Seagate 4GB SCSI Drive with controller added
3.5" 1.44MB diskette drive
12X CD-ROM drive
E Series Desktop case
3COM PCI 10/100 twisted pair Ethernet added
104+ Keyboard
MS IntelliMouse mouse & Gateway mouse pad

NT4.0 (@$100.)
Office Pro 97 (@ $50.)
FrontPage 98 (@ $33.) 32
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Glossary of Terms Related to This Guide's Use

Bookmark A marked location within a web page that is often used for quick navigation within a page
that has a great deal of text. It allows the viewer to move directly to a section of the page of
greatest interest.

Browser A client software program for viewing Web sites that is sent by a server over an http//: connection.
The most common Web browsers are Netscape Navigator and Microsoft Explorer.

Domain Name (DNS) Domain Name System; a unique name that is matched to the IP number of your system; it is
used to identify each Internet site (the computer address on the intemet). For example, the
Los Rios Community College District Office of Institutional Research has the domain name
of irweb.do.losrios.cc.ca.us

Frame and Frame Set Frames divide the Web browser's display into windows, each of which can contain a
separate, scrollable page. A group of frames is called a frame set (often referred to as a web
page consisting of multiple panes). The minimum number of panes in a frame set is two. In
the implementation of a frame set, there is usually one pane reserved for navigation and one
pane reserved for the actual content. The purpose of using a frame set is to make it easier to
navigate a complex site.

Frame Target The pane within a frame set to which you are pointing, creating a hyperlink or referring to in
another way.

FrontPage

FrontPage Editor

FrontPage Explorer

A Microsoft application that enables you to design, create, edit, save and publish your own
web site.

The component of FrontPage that is used to create and edit individual web pages. Using the
Editor, you can enter text, format it, format the page itself, insert images on the page, create
links, insert tables, and the like. It works much like any word processor in that it enables
you to type text, open and save files and format text as you do with word processors.

The component of FrontPage that serves as the administration tool, allowing you to manage,
and delete entire webs. With FrontPage Explorer, you have an overall picture of your entire
Web.

FTP File Transfer Protocol; the TCP/IP protocol for transferring files on the Intranet.

. GIF One of the two allowable graphic image file formats available on a web page. The other is
jpg (or .jpeg)

Home Page The default, or entry, page of a Web site; all other pages are subordinate to it. It usually has
the domain name as its name.

HTML HperText Markup Language; the programming language used to create web pages. The
HTML code used to create the pages is hidden from the viewer not only in the browser but in
Microsoft FrontPage, as well.

http:// HyperText Transfer Protocol; the client/server protocol that is used for moving to hypertext
files on the Internet.

Internet The worldwide network of computers connected by TCP/IP and other Internet working
protocols.

.jpg (or .jpeg) One of the two allowable graphic image file formats available on a Web page. The other is
.GIF.

33
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Link A pointer (or connection) to another location within a web site or across the Web. When users
click on a link, the browser they are using will retrieve and display the contents of the page you
are connecting (or linking) to.

Hyperlink View One of the two views available in FrontPage Explorer. It graphically represents the
relationships of pages within a Web site.

Folder View One of the two views available in FrontPage Explorer. It displays the relationships between
web files and the folders in which they are organized.

Personal Web Server A 32-bit Web server included with Front Page. It is compatible with the http protocol.

Properties The options that control how you wish to display a given Web component or page.

TCP/IP Transmission Control Protocol/Internet Protocol; TCP/IP is a set of protocols developed to
allow cooperating computers to share resources across a network. This suite of protocols
provides the infrastructure for the Internet.

URL

Web Site

Web Page

Universal Resource Locator; URL is a standard for identifying the full path of a document,
graphic, or other file on the Internet (or on an organization's internal intranet). A URL
expresses the protocol (such as FTP or HTTP) to be accessed and the file's location. Some
examples of URLs are:
http://www.someones.homepage/default.html
ftp://ftp.server.somewhere/ftp.file
gopher://server.name

The collection of Web pages that make up a given organization or department of an
organization's information published on the World Wide Web. It consists of a Home Page
(the default or point of entry) and all related HTML pages that are subordinate links to it.

A component of a Web site; a single document or text file written in HTML code. It provides
the actual information that you publish on it to be viewed by Internet users who reaches your
Web Site and navigates within it.

Note: This guide can be downloaded directly from the Los Rios Community College District IR
Web site

http://irweb.do.losrios.cc.ca.us
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